Integration SVN

Deutschsprachiges Forum für Diskussionen und Fragen zu MantisBT

Moderators: Developer, Contributor

Post Reply
haentschman
Posts: 43
Joined: 25 Mar 2016, 15:52

Integration SVN

Post by haentschman »

Hallo alle... :P

Ich habe bei mir die SVN Integration incl. dem WebSVN erfolgreich zum Laufen gebracht. 8) Nun wollte ich das analog in der Firma machen...Fehler bis zum Abwinken. :evil: Die Fehlermeldungen kann ich dummerweise nur aus dem Kopf wiedergeben da alles wieder zurückgesetzt wurde... Zu viel Arbeitszeit versenkt. :roll:

Gegebenheiten privat (funktional):
Mantis auf Webspace 1und1, PHP 5.6
WebSVN auf Webspace 1und1, PHP 5.6
SVN über dynDNS Adresse auf einem Windows Computer (privat)

Gegebenheiten Firma:
Mantis auf QNAP NAS mit Webserver, PHP 5.5
WebSVN auf QNAP NAS mit Webserver, PHP 5.5
SVN im lokalen Netz auf Windows SBS
...auf dem QNAP läuft, lt. Systeminfo ein Ubuntu 4.1.2 (ohne Gewähr) :wink:

1. Fehler:

Als erstes wollte ich den WebSVN zum Laufen bekommen weil der ja für die Mantis Integration Voraussetzung ist. Schon beim default config File kommt der rosa Hinweis auf addRepository (korrekt) und schon in den ersten Zeilen steht:
Error running this command: svn --config-dir /tmp --version
sh: svn: command not found
:roll: Was sucht der da? Da ist doch noch nichts konfiguriert? Der Tenor des Web Informationen ist ein Path Problem zur Command Line. Auf meinem Webspace mußte ich auch nichts konfigurieren. Nach dem Eintrag eines Repositories kommt nur noch der Fehler.

2. Fehler.
Mantis Projektarchiv... Nach dem Anlegen eines Projektarchives und bei jeder Importaktion (letzte/alle) kommt in der ersten Zeile ganz groß
Application ERROR #0
Wenn du willst kannst du das dem Administrator erzählen... oder so :wink:
was wir (ohne Erfolg) probiert haben:
Portfreigaben sowohl auf dem SBS als auch QNAP eingerichtet.
Path Variable (zum SVN bin) auf dem SBS geprüft. Identisch wie bei mir.
Auf dem SBS beim SVN habe ich einen WireShark auf dem entsprechendem Port am laufen. Sowohl vom WebSVN als auch beim Import kommt keine http Anfrage (auf dem Port) beim SBS an. Beim manuellen Ausführen des Kommandos zum SVN über die QNAP Konsole kommt die Anfrage ordentlich beim SBS an. Damit dürfte die Frage nach der Firewall sich erledigt haben.

Persönlich traue ich dem QNAP Webserver nicht. Auch die Grafik Integration MantisBTGraph funktioniert weder mit der integrierten als auch mit JpGraph. Da gibt es sowas wie "Datei nicht gefunden" auf einem merkwürdigem Pfad.

Welche Tipps hättet ihr für mich um die Ursache zu definieren?

Danke... :P
Attachments
configuration.png
configuration.png (33.94 KiB) Viewed 4435 times
Post Reply