REST API

Deutschsprachiges Forum für Diskussionen und Fragen zu MantisBT

Moderators: Developer, Contributor

Post Reply
Andi_1993
Posts: 3
Joined: 12 Apr 2022, 14:51

REST API

Post by Andi_1993 »

Hallo zusammen,

vielleicht kann mir hier jemand helfen und zwar habe ich folgendes Problem.

Ich kann meine Daten per REST API ohne Probleme abrufen, das klappt alles wunderbar. Aber wir haben etliche Custom_Fields in unserer Umgebung, von welchen ich keine Daten zurückbekomme.

Bzw anscheinend ruft er was ab, kann es aber dann nicht darstellen.... siehe Screenshot.

Und auch sieht die JSON Response nicht so aus wie im API Handbuch von Mantis.
https://documenter.getpostman.com/view/ ... pi/7Lt6zkP

Vielleicht hat jemand noch eine Idee - bin für alle Vorschläge offen.

Umgebung:

Windows Server mit XAMPP
Apache 2.24
PHP 7.24
Mantis 2.25.2
Attachments
BUg.JPG
BUg.JPG (46.83 KiB) Viewed 12013 times
atrol
Site Admin
Posts: 8402
Joined: 26 Mar 2008, 21:37
Location: Germany

Re: REST API

Post by atrol »

Habe keine Zeit, um es mir genauer anzuschauen.
Schuss in's Blaue: Es Könnte ein Zusmmanhang mit diesem Problem bestehen: https://mantisbt.org/bugs/view.php?id=29413
Please use Search before posting and read the Manual
Andi_1993
Posts: 3
Joined: 12 Apr 2022, 14:51

Re: REST API

Post by Andi_1993 »

Also konnte gestern Abend noch die Datenbank samt Tabellen in unserer Test-Umgebung zu konvertieren (sowohl in UTF8MB4_General_CI und UTF8MB4_Unicode_CI) leider brachte dies aber keinen Erfolg.

Die Daten aus dem Custom Fields werden trotzdem nicht angezeigt.
Andi_1993
Posts: 3
Joined: 12 Apr 2022, 14:51

Re: REST API

Post by Andi_1993 »

Habe heute auch noch einmal einen Versuch gestartet auf einer frischen Neuinstallation - aber auch hier leider kein brauchbares Ergebnis. Die Custom Fields bleiben weiterhin "leer" wenn Sie per REST angesprochen werden.
Post Reply