One mail, two bugs reported

This plugin allows you to report an issue in MantisBT by sending an email to a particular mail account

Moderators: Contributor, Developer

Post Reply
jcgallardo
Posts: 4
Joined: Mar 30, 2016 9:14 am

One mail, two bugs reported

Post by jcgallardo » Jan 23, 2019 12:33 pm

Mantis 2.18.0
EmailReporting 0.10.1

I have configured a IMAP Folder in an Office 365 mailbox. We have configured email reporting to not to delete the emails procesed.

I received an email three weeks ago, and when I put it in autoreporting folder, email reporting added this mail as a new incident with id-bug-number 87000. We resolved the incident and close the bug, but we didn't delete the email from the autoreporting folder.

Today we see that Emailreporting had procesed the mail again and create a new incident with id-bug-number 88000.

I have reviewed the 'mantis_plugin_emailreporting_msgids_table' and I surprised to see that the old bug (id-87000) didn't have a msg_id, and the new bug (id-88000) had the msg_id that corresponding to the email.

How is it possible? Is a bug or a user action?


P.D: Email reporting didn´t associate the bugs.

SL-Gundam
Posts: 553
Joined: Jul 06, 2011 9:17 am

Re: One mail, two bugs reported

Post by SL-Gundam » Jan 23, 2019 5:17 pm

IMAP works differently from POP3 when it concerns the deletion of emails: Please read this: http://www.mantisbt.org/wiki/doku.php/m ... ilbox_type

IMAP towards Exchange has always been an issue because of an incomplete IMAP4rev1 implementation on the exchange side. EmailReporting 0.9.x and 0.10.x fixed a lot of issues with Exchange but as you've noticed it is not perfect

If issues are deleted from MantisBT, the references are also deleted from mantis_plugin_emailreporting_msgids_table
Are you triggering EmailReporting manually to import emails or does it happen on a schedule?

jcgallardo
Posts: 4
Joined: Mar 30, 2016 9:14 am

Re: One mail, two bugs reported

Post by jcgallardo » Feb 14, 2019 6:57 am

Thanks for your answer.

I have configured a scheduled task to run every 2 minutes. If the task is running, we doesnt launch a new instance task.

We don't delete bugs, we only close it.

I have a XAMPP instalacion on Windows Server 2012, the Mantis version is 2.18.0 and the emailreporting is version 0.10. Some month ago, we have Mantis version 1.3 and emailreporting version 0.9 and never had this problem.

Do you know what can we do to resolve it?

SL-Gundam
Posts: 553
Joined: Jul 06, 2011 9:17 am

Re: One mail, two bugs reported

Post by SL-Gundam » Feb 14, 2019 1:36 pm

What might have happened is that EmailReporting did not fully run to completion.
If EmailReporting encounters a fatal error before fully finishing the mailbox, emails are not deleted/marked as read.

We've recently found an issue with reference id parsing.
https://github.com/mantisbt-plugins/Ema ... 5bb7939d35

Please update to 0.11.0-DEV and see if that works better

Post Reply