APPLICATION ERROR #401, database error#1064

Get help from other users here.

Moderators: Contributor, Developer

Post Reply
krell66
Posts: 1
Joined: Jun 13, 2019 9:30 am

APPLICATION ERROR #401, database error#1064

Post by krell66 » Jun 13, 2019 9:53 am

Hi,
after an automatic upgrade (current Mantisbt revision is now 2.9.0) when I try to:
- "Manage Projects", "Global Categories" and "Edit" one of Global Categories
the following screen appears:

APPLICATION ERROR #401
Database query failed. Error received from database was #1064: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '' at line 4 for the query: SELECT id, username, realname, access_level
FROM mantis_user_table
WHERE enabled = ?
AND access_level >= .
Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.


The same happens when I try to view an issue, selecting related ID.

Is anybody who can help me?

Thanks

More information about Mantisbt I am using are the following:
Synology Diskstation
MantisBT Version 2.9.0
Schema Version 183
PHP Version 5.6.40
Database Driver mysqli
Database Version, Description 10.3.11, 10.3.11-MariaDB
Site Path /volume1/web/mantisbt/
Core Path /volume1/web/mantisbt/core/
Plugin Path /volume1/web/mantisbt/plugins/


mmorag
Posts: 1
Joined: Jun 14, 2019 10:59 am

Re: APPLICATION ERROR #401, database error#1064

Post by mmorag » Jun 14, 2019 11:54 am

Same error when I try to view an issue or selecting related ID, as well as trying to accesing to Admin-config / transition or email-not.

I migrated old mysql (with lots of issues) and mantis version:

Old mysql ver.: 5.1.73 -> Migrated to: 5.7.26 MySQL Community Server (restoring db to the new one - bck-using mysqldump)
Old Mantis ver.: 1.2.19 -> Migrated to: 2.21

Addly, when I try to filter with "Assigned to", it shows "error: Internal Server Error".

Restoring database was successfully, and using install.php, I updated db manually using sql sentences given by installer.

Somebody has any idea how to solve it?. thks.

atrol
Site Admin
Posts: 7615
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: APPLICATION ERROR #401, database error#1064

Post by atrol » Jun 14, 2019 2:10 pm

Go back to your 1.2.19 dump and try the following steps
- clear browser cookies
- run install script to upgrade the database (don't do it manually)
- try if it works
- in any case run admin/check/index.php after the upgrade and check for errors and warnings
Please use Search before posting and read the Manual

Post Reply