Can't Upgrade MantisBT 1.1.8 to 2.22.0

Get help from other users here.

Moderators: Developer, Contributor

Post Reply
tomsnunes
Posts: 2
Joined: Aug 08, 2019 6:34 am
Location: São Paulo, Brazil

Can't Upgrade MantisBT 1.1.8 to 2.22.0

Post by tomsnunes » Aug 30, 2019 6:56 am

Hello guys

I'm a new software developer of a company which has using MantisBT as bugtracker for a long time, the problem is that I have assumed an old and modified version of MantisBT (1.1.8) and now I am in charge of update this mess to the latest version.

The modifications insert into MantisBT core was basically a timetracker to keep data of time used per project.

I've clean up everything which was modified in the core and now these modifications are working as a plugin in the latest version of Mantis, but unhapply, after a long way of search in this forum and reading the docs, I can't find a way to update my database schema (mantis_config_table show schema as database_version 6) of the version 1.1.8 to 2.22.0.

I've tried through the admin/install.php script, but no lucky with that. The process cant be completed.

I'm ready to try something more manual related to manipulate the database.

Precisily I need to import the reported bugs and its dependencies like attachments, descriptions fields and bug ids to the new version.

Everything in my project is running in a local development environment using Windows 10 IIS, PHP-CGI (PHP 5.5.0 to MantisBT 1.1.8 and PHP 7.3.8 to MantisBT 2.22.0) and MySQL version 8.0.17 and 5.7.26.

Sincerily guys, as I said, I've read every post in these forum and followed the instructions, but no results until now.

Would someone give me a direction or other aproach to that situation?

Sorry about my english, I'm not native.

Thanks in advance.
Mantis: 1.1.8 / 2.22.0
PHP: FastCGI 5.5.0 / FastCGI 7.3.8
SQL: MySQL 5.5.62 / 8.0.17.0
OS: Windows 10 Pro Build 1903 / Windows Server 2012 R2
Web Server: IIS 10 (Local)

dregad
Developer
Posts: 39
Joined: Jul 26, 2010 9:24 am

Re: Can't Upgrade MantisBT 1.1.8 to 2.22.0

Post by dregad » Sep 04, 2019 10:15 am

I've tried through the admin/install.php script, but no lucky with that. The process cant be completed.
Can you be a bit more specific as to why it can't be completed ? Error messages, etc ?

I would assume the upgrade process fails because the database has been altered. You could try
  • reverting these changes to go back to a standard 1.1.8 schema matching
  • generate SQL instead of executing the script, and run that (but be aware that there are also procedural changes such as data conversions, that would not be applied in this case)
  • manually applying the upgrade steps one by one (see admin/schema.php)

tomsnunes
Posts: 2
Joined: Aug 08, 2019 6:34 am
Location: São Paulo, Brazil

Re: Can't Upgrade MantisBT 1.1.8 to 2.22.0

Post by tomsnunes » Sep 10, 2019 6:28 am

Hey guys!
Sorry to not share the specific errors I was getting.
I've complete the upgrade process by manual adding the database_version entry in database and changing it value incremetaly step by step. Maybe this can help someone.

Now everything is running fine.
Thank you for be ready to help me.
Mantis: 1.1.8 / 2.22.0
PHP: FastCGI 5.5.0 / FastCGI 7.3.8
SQL: MySQL 5.5.62 / 8.0.17.0
OS: Windows 10 Pro Build 1903 / Windows Server 2012 R2
Web Server: IIS 10 (Local)

Post Reply