Upgrade from Mantis 1.2.16

Get help from other users here.

Moderators: Developer, Contributor

Post Reply
pbassi
Posts: 8
Joined: Sep 15, 2016 6:21 am

Upgrade from Mantis 1.2.16

Post by pbassi » Jan 10, 2020 10:42 am

Hi everyone,

I am trying to update our current installation of Mantis (1.2.16) to the last release (e.g. 2.23.0).
On a new Linux server we installed
MySql 8.0.17
PHP 7.2.24
Apache 2.4.6

then we cloned the current Mantis-Version 1.2.16 to the new server and we are now having problems with the PHP Version.
I was thinking to proceed as follows:

1. install a previous version of PHP (e.g. 5.6 as recommended by Atrol)
2. Upgrade Mantis
3. install PHP 7.x

Would that be the right approach?

Thanks in advance for your replies!

cas
Posts: 712
Joined: Mar 11, 2006 11:08 am
Contact:

Re: Upgrade from Mantis 1.2.16

Post by cas » Jan 13, 2020 10:18 am

Do the upgrade on the old server, next move the instance to the new server.
Your alternative approach will also work.

pbassi
Posts: 8
Joined: Sep 15, 2016 6:21 am

Re: Upgrade from Mantis 1.2.16

Post by pbassi » Jan 14, 2020 9:44 am

Thanks for your message.
I cannot upgrade on the old server, because we cannot stop the users :(

cas
Posts: 712
Joined: Mar 11, 2006 11:08 am
Contact:

Re: Upgrade from Mantis 1.2.16

Post by cas » Jan 14, 2020 9:50 am

You will have to stop them anyway otherwise you may loose data. A scheduled outage is quite normal in such cases.

pbassi
Posts: 8
Joined: Sep 15, 2016 6:21 am

Re: Upgrade from Mantis 1.2.16

Post by pbassi » Jan 20, 2020 9:21 am

Thank you!

we will stop the users the shortest time possible.

Do you know what version of PHP we should re-install in order to be able to run the upgrade?
On the old server we had PHP 5.3.3 and when I started the upgrade I've got the message PHP was too old...

Thanks!

cas
Posts: 712
Joined: Mar 11, 2006 11:08 am
Contact:

Re: Upgrade from Mantis 1.2.16

Post by cas » Jan 20, 2020 10:22 am

Suggest you follow the standard recommendations

Post Reply