i have an issue in configuring mailbox in Emailreporting plugin

This plugin allows you to report an issue in MantisBT by sending an email to a particular mail account

Moderators: Developer, Contributor

Post Reply
hosainy
Posts: 2
Joined: Feb 12, 2020 11:35 am

i have an issue in configuring mailbox in Emailreporting plugin

Post by hosainy »

Hello, I'm new here.. i have a problem regarding my configuration in mantis email reporting plugin.
im using mantis 2.13.1
Email reporting plugin 0.10.1
php 7.2.24-0
ubuntu 18
im getting this error while i try to run the script bug_report_mail.

Code: Select all

array(14) {
  ["enabled"]=>
  int(1)
  ["description"]=>
  string(20) "imap_test_non_secure"
  ["mailbox_type"]=>
  string(4) "IMAP"
  ["hostname"]=>
  string(18) "mail.maxnet-is.ae "
  ["port"]=>
  int(143)
  ["encryption"]=>
  string(4) "None"
  ["ssl_cert_verify"]=>
  int(1)
  ["erp_username"]=>
  string(22) "xxxxxx@maxnet-is.ae"
  ["erp_password"]=>
  string(12) "xxxxxxx="
  ["auth_method"]=>
  string(4) "USER"
  ["project_id"]=>
  int(2)
  ["global_category_id"]=>
  int(3)
  ["imap_basefolder"]=>
  string(0) ""
  ["imap_createfolderstructure"]=>
  int(0)
}

Mailbox: imap_test_non_secure
Message: Failed to connect to the mail server
and this is my cronjob using crontab -e

Code: Select all

*/5 *   *   *   * /usr/local/bin/php /path/to/mantis/plugins/EmailReporting/scripts/bug_report_mail.php
what ami doing wrong here?
where should i start when im configuring it for the first time? i didnt get it quite well using the guide. lol still a beginner

SL-Gundam
Posts: 582
Joined: Jul 06, 2011 9:17 am

Re: i have an issue in configuring mailbox in Emailreporting plugin

Post by SL-Gundam »

I see a space at the end of the hostname
["hostname"]=>
string(18) "mail.maxnet-is.ae "
Just tested whether this is an issue... and yes it is.
So remove the space and everything should work

hosainy
Posts: 2
Joined: Feb 12, 2020 11:35 am

Re: i have an issue in configuring mailbox in Emailreporting plugin

Post by hosainy »

yeah i fixed it and everything is working okay.
I have another question i didnt understand quite well.. "Save email contents to this directory if debug mode is activated" , i dont know which directory i should put.

SL-Gundam
Posts: 582
Joined: Jul 06, 2011 9:17 am

Re: i have an issue in configuring mailbox in Emailreporting plugin

Post by SL-Gundam »

Thats only interesting when trying to solve an issue with the way an email is processed.
EmailReporting will save a raw_msg file (which contains the email as received from the mail server) and parsed_msg file (which contains the parsed version of the email)

Post Reply