Installation Error PHP 8

General discussion of Mantis.

Moderators: Developer, Contributor

Post Reply
jav666
Posts: 2
Joined: 24 Feb 2023, 10:34

Installation Error PHP 8

Post by jav666 »

Surely it can't be that PHP 8 is not supported?

Image

Image
jav666
Posts: 2
Joined: 24 Feb 2023, 10:34

Re: Installation Error PHP 8

Post by jav666 »

ok. PHP 8.2 is not supported.

Image

Install! Yeah!

Image

and then:

Image

Code: Select all

Fatal error: Uncaught mysqli_sql_exception: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'schema()schema()' at line 5 in /homepages/5/d245225137/htdocs/bugtracker/vendor/adodb/adodb-php/drivers/adodb-mysqli.inc.php:788 Stack trace: #0 /homepages/5/d245225137/htdocs/bugtracker/vendor/adodb/adodb-php/drivers/adodb-mysqli.inc.php(788): mysqli_query(Object(mysqli), 'SELECT\n\t\t\tTABLE...', 0) #1 /homepages/5/d245225137/htdocs/bugtracker/vendor/adodb/adodb-php/adodb.inc.php(1268): ADODB_mysqli->_query('SELECT\n\t\t\tTABLE...', false) #2 /homepages/5/d245225137/htdocs/bugtracker/vendor/adodb/adodb-php/adodb.inc.php(1246): ADOConnection->_Execute('SELECT\n\t\t\tTABLE...', false) #3 /homepages/5/d245225137/htdocs/bugtracker/vendor/adodb/adodb-php/adodb.inc.php(2579): ADOConnection->Execute('SELECT\n\t\t\tTABLE...') #4 /homepages/5/d245225137/htdocs/bugtracker/vendor/adodb/adodb-php/drivers/adodb-mysqli.inc.php(569): ADOConnection->MetaTables('TABLE', false) #5 /homepages/5/d245225137/htdocs/bugtracker/core/database_api.php(854): ADODB_mysqli->MetaTables('TABLE') #6 /homepages/5/d245225137/htdocs/bugtracker/core/database_api.php(492): db_get_table_list() #7 /homepages/5/d245225137/htdocs/bugtracker/core/config_api.php(82): db_table_exists('uln3_config_tab...') #8 /homepages/5/d245225137/htdocs/bugtracker/core/lang_api.php(193): config_get('language_choice...') #9 /homepages/5/d245225137/htdocs/bugtracker/core/user_pref_api.php(611): lang_language_exists('auto') #10 /homepages/5/d245225137/htdocs/bugtracker/core/lang_api.php(115): user_pref_get_language(1) #11 /homepages/5/d245225137/htdocs/bugtracker/core/error_api.php(164): lang_get_default() #12 [internal function]: error_handler(256, '-1', '/homepages/5/d2...', 92) #13 /homepages/5/d245225137/htdocs/bugtracker/core/error_api.php(92): trigger_error('-1', 256) #14 [internal function]: error_exception_handler(Object(mysqli_sql_exception)) #15 {main} thrown in /homepages/5/d245225137/htdocs/bugtracker/vendor/adodb/adodb-php/drivers/adodb-mysqli.inc.php on line 788
Last edited by jav666 on 24 Feb 2023, 10:57, edited 1 time in total.
atrol
Site Admin
Posts: 8402
Joined: 26 Mar 2008, 21:37
Location: Germany

Re: Installation Error PHP 8

Post by atrol »

Does it work with 2.25.5?
If yes, please create a bug report at https://www.mantisbt.org/bugs
Please use Search before posting and read the Manual
Post Reply