View Issue Details

IDProjectCategoryView StatusLast Update
0021096mantisbtemailpublic2016-06-27 10:09
Reportercproensa Assigned Toatrol  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionduplicate 
Summary0021096: support notification user preferences at project level
Description

User preferences for notification emails should be configurable for each project.

In my use case, i have a team of developers that are assigned to a big number of projects.
All of them should have the same access to those projects, but not all of them work on them actively.
So developer A might only want detailed notifications for those projects that is actively working in, and "silence" those projects that dont, maybe just enabling the assignment emails.

This will help reduce the number of emails that are sent, to those that the user specifically wants.
It also helps with 3rd party email providers which may have quotas on emails sent.

In my specific case, i'm hitting around 15k emails per day, which is hard to bring down due to this situation, and also creates a burden on the user that have to manage some extensive email filters at client side.

TagsNo tags attached.

Relationships

duplicate of 0005637 confirmed Project based email notification setting 
related to 0020323 new Update schema to support user preferences for more email events 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2016-06-12 18:40 cproensa New Issue
2016-06-12 18:41 cproensa Relationship added related to 0020323
2016-06-12 19:12 atrol Assigned To => atrol
2016-06-12 19:12 atrol Status new => resolved
2016-06-12 19:12 atrol Resolution open => duplicate
2016-06-12 19:12 atrol Relationship added duplicate of 0005637
2016-06-27 10:09 atrol Status resolved => closed