View Issue Details

IDProjectCategoryView StatusLast Update
0023756mantisbtcustom fieldspublic2017-12-30 18:36
ReportermiqrogrooveAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version2.2.1 
Target VersionFixed in Version 
Summary0023756: Multiselection list field in Issue History Always Shows New Value Instead of Old Value
Description

When a custom field of type "Multiselection list" is in use for a project, this field is added to the Issue History every time the bug is modified, even when the value for that field has not changed. The only exception is when there is no selection. For example, if I select one from the list, "Apples", the Issue History will say "Apples => Apples" even though the old value was null. Then, if I change the bug status, my previous list selections appear again in Issue History as "Apples => Apples", for no good reason. This History item "Apples => Apples" is repeated for every bug edit.

Tested on 2.2.1 and 2.9.0.

TagsNo tags attached.

Relationships

duplicate of 0022408 assigneddregad Custom field's value logged as changed in history, when it wasn't changed 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2017-12-28 08:27 miqrogroove New Issue
2017-12-28 17:53 atrol Assigned To => atrol
2017-12-28 17:53 atrol Status new => resolved
2017-12-28 17:53 atrol Resolution open => duplicate
2017-12-28 17:53 atrol Relationship added duplicate of 0022408
2017-12-30 18:36 vboctor Status resolved => closed