View Issue Details

IDProjectCategoryView StatusLast Update
0028333mantisbtinstallationpublic2021-05-01 14:33
Reporterjavsalgar Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version2.25.0 
Summary0028333: Cannot move core folder outside the mantis webroot
Description

I tried moving the core folder outside the mantis webroot (as suggested by the admin checks), but it fails with the following error

PHP Fatal error:  require_once(): Failed opening required '/opt/bitnami/mantis/core/constant_inc.php' (include_path='.:/opt/bitnami/php/lib/php') in /opt/bitnami/mantis/core.php on line 69

Checking the core.php file I see the following (line 69)

# Load supplied constants
require_once( dirname( __FILE__ ) . DIRECTORY_SEPARATOR . 'core' . DIRECTORY_SEPARATOR . 'constant_inc.php' );

Note that this path is not using the g_core_path global variable, therefore the issue

Steps To Reproduce

Move the core folder outside the mantis installation

TagsNo tags attached.

Relationships

duplicate of 0021584 new core_path directory can't be moved outside the web root 

Activities

There are no notes attached to this issue.