View Issue Details

IDProjectCategoryView StatusLast Update
0008385mantisbtdb db2public2007-10-04 01:37
Reportervboctor Assigned Tovboctor  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.1.0a4 
Target Version1.1.0rc1Fixed in Version1.1.0rc1 
Summary0008385: ADODB_db2._insert_id doesn't work
Description

Following is the fix reported by Alan Seiden:

function _insertid()
{

// original: return ADOConnection::GetOne('VALUES IDENTITY_VAL_LOCAL()');
// Alan Seiden DB2
return ADOConnection::GetOne('SELECT IDENTITY_VAL_LOCAL() FROM SYSIBM.SYSDUMMY1');
}

This bug was reported to ADODB author via email since they don't seem to have a formal bug reporting process.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2007-09-22 04:16 vboctor New Issue
2007-09-22 04:16 vboctor Status new => assigned
2007-09-22 04:16 vboctor Assigned To => vboctor
2007-09-22 04:17 vboctor Status assigned => resolved
2007-09-22 04:17 vboctor Fixed in Version => 1.1.0rc1
2007-09-22 04:17 vboctor Resolution open => fixed
2007-10-04 01:37 vboctor Status resolved => closed