View Issue Details

IDProjectCategoryView StatusLast Update
0008386mantisbtdb db2public2007-10-04 01:37
Reportervboctor Assigned Tovboctor  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.1.0a4 
Target Version1.1.0rc1Fixed in Version1.1.0rc1 
Summary0008386: ADODB_db2 uses an invalid time format which is not accepted by db2
Description

This patch was submitted by Alan Seiden:

// original:  var $fmtTimeStamp = "'Y-m-d-H:i:s'";
// DB2 valid formats: Y-m-d-H.i.s (IBM SQL format, center dash and dots) or Y-m-d H:i:s (ISO format, center space and colons). We'll use ISO: Y-m-d H:i:s  
var $fmtTimeStamp = "'Y-m-d H:i:s'";

The patch was also submitted to ADODB author via email since they don't seem to use an bug tracker. This bug applies to both ADODB 4.94 and the current ADODB 5.xx as of this date.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2007-09-22 04:22 vboctor New Issue
2007-09-22 04:22 vboctor Status new => assigned
2007-09-22 04:22 vboctor Assigned To => vboctor
2007-09-22 04:25 vboctor Status assigned => resolved
2007-09-22 04:25 vboctor Fixed in Version => 1.1.0rc1
2007-09-22 04:25 vboctor Resolution open => fixed
2007-10-04 01:37 vboctor Status resolved => closed