View Issue Details

IDProjectCategoryView StatusLast Update
0008387mantisbtdb db2public2007-10-04 01:37
Reportervboctor Assigned Tovboctor  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.1.0a4 
Target Version1.1.0rc1Fixed in Version1.1.0rc1 
Summary0008387: adodb2-db2.DBTimeStamp uses TO_DATE() which doesn't work on DB2
Description

Patch reported by Alan Seiden:

// format and return date string in database timestamp format
function DBTimeStamp($ts)
{
    if (empty($ts) && $ts !== 0) return 'null';
    if (is_string($ts)) $ts = ADORecordSet::UnixTimeStamp($ts);

            // original: return 'TO_DATE('.adodb_date($this->fmtTimeStamp,$ts).",'YYYY-MM-DD HH24:MI:SS')";
    return adodb_date($this->fmtTimeStamp,$ts);
}

This patch was reported to ADODB author via email since they don't seem to use a bug tracker.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2007-09-22 04:34 vboctor New Issue
2007-09-22 04:34 vboctor Status new => assigned
2007-09-22 04:34 vboctor Assigned To => vboctor
2007-09-22 04:38 vboctor Status assigned => resolved
2007-09-22 04:38 vboctor Fixed in Version => 1.1.0rc1
2007-09-22 04:38 vboctor Resolution open => fixed
2007-10-04 01:37 vboctor Status resolved => closed