Mail configuration

Get help from other users here.

Moderators: Developer, Contributor

Post Reply
ramesh.g
Posts: 5
Joined: Apr 12, 2013 4:55 am

Mail configuration

Post by ramesh.g » May 28, 2013 4:46 am

Hi,

When i am resetting password the mail is not going from Mantis and when i checked the log message it is showing
2013-05-28 11:42 CEST mail Password reset for email = ramesh.g@mydomain
2013-05-28 11:42 CEST mail Processing e-mail queue (1 messages)
2013-05-28 11:42 CEST mail Sending message #61 queued on 2013-05-28 11:42 CEST
2013-05-28 11:42 CEST mail message #61 deleted from queue

Any idea to override this???

atrol
Site Admin
Posts: 7692
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Mail configuration

Post by atrol » May 28, 2013 10:11 am

I don't see any problem in the log.
The mail is sent and after that deleted from the queue.
Please use Search before posting and read the Manual

ramesh.g
Posts: 5
Joined: Apr 12, 2013 4:55 am

Re: Mail configuration

Post by ramesh.g » May 29, 2013 3:59 am

atrol wrote:I don't see any problem in the log.
The mail is sent and after that deleted from the queue.
Now in the log i am getting

server error: 5.7.1 Unable to relay

I am getting this error when i try to add different domain users. (Client)

atrol
Site Admin
Posts: 7692
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Mail configuration

Post by atrol » May 29, 2013 4:15 am

Please use Search before posting and read the Manual

ramesh.g
Posts: 5
Joined: Apr 12, 2013 4:55 am

Re: Mail configuration

Post by ramesh.g » Jun 04, 2013 7:28 am

Hi Atrol,

I found some issue in Mantis with gmail configuration.

Earlier i have used xampp-win32-1.7.3 and mantisbt-1.2.15.
The below configuration is working fine for gmail and any domain.
<?php
$g_hostname = 'localhost';
$g_db_type = 'mysql';
$g_database_name = 'bugtracker';
$g_db_username = 'root';
$g_db_password = '';
$g_phpMailer_method = PHPMAILER_METHOD_SMTP;
$g_smtp_host = 'smtp.gmail.com';
$g_smtp_username = 'mymailid';
$g_smtp_password = 'pwd';
$g_smtp_connection_mode = 'ssl';
$g_smtp_port = 465;
?>
But if i use xampp-win32-1.8.1-VC9 with mantisbt-1.2.15 the above config_inc is not working.
when i check the log i got
ERROR: Message could not be sent - SMTP Error: Could not connect to SMTP host.
the same gmail config i have modified as below(with quotes)
$g_phpMailer_method = 'PHPMAILER_METHOD_SMTP';
then i got the log as
2013-06-04 14:16 CEST mail Sending message #5 queued on 2013-06-04 14:16 CEST
2013-06-04 14:16 CEST mail message #5 deleted from queue
but unfortunately i have not received any mails :(

atrol
Site Admin
Posts: 7692
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Mail configuration

Post by atrol » Jun 05, 2013 10:39 am

ramesh.g wrote: Earlier i have used xampp-win32-1.7.3 and mantisbt-1.2.15.
The below configuration is working fine for gmail and any domain.
...
But if i use xampp-win32-1.8.1-VC9 with mantisbt-1.2.15 the above config_inc is not working.
It's quite obvious that this no MantisBT but a XAMPP problem.
Maybe caused by a bug in XAMPP, maybe by a more restrictive PHP setting, ...
Check the log files of XAMPP for any errors/warnings
ramesh.g wrote: $g_phpMailer_method = 'PHPMAILER_METHOD_SMTP';
This makes no sense. PHPMAILER_METHOD_SMTP is a numeric constant and not a string.
Don't use quotes as you will get unexpected results. You will probably not connect to the SMTP server that you configured.
Please use Search before posting and read the Manual

Post Reply