Unable to Upgrade

General discussion of Mantis.

Moderators: Developer, Contributor

Post Reply
wdolson
Posts: 22
Joined: Jan 28, 2008 6:15 am

Unable to Upgrade

Post by wdolson » Jun 04, 2018 8:34 pm

We've been running an older version of Mantis. The old version is in Mantis1_2_15, but I think we upgraded to a 1.3.x version. Most of the files in the version we've been using are dated 11/19/2016.

Anyway another app running on the same server needed PHP 7 and Mantis quit working shortly after they upgraded. I've been tasked with upgrading Mantis to a newer version.

I created a new directory Mantis2_14_0 and tried to run admin/install.php. I get the following message and nothing else:

INTERNAL APPLICATION ERROR

Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.

I tried opening up the permissions in the Mantis 2.14.0 directory 777 temporarily, but that didn't work.

Any idea what this message is trying to tell me?

atrol
Site Admin
Posts: 7658
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Unable to Upgrade

Post by atrol » Jun 05, 2018 12:37 am

Do see see any errors or warnings in webserver or PHP logs?

What do you get when running <YourMantisURL>/admin/check/index.php
Please use Search before posting and read the Manual

wdolson
Posts: 22
Joined: Jan 28, 2008 6:15 am

Re: Unable to Upgrade

Post by wdolson » Jun 05, 2018 1:22 am

It looks like they shut off mysql support when they upgraded PHP

Database type is supported by the version of PHP installed on this server
The current database type is set to mysql. The version of PHP installed on this server does not have support for this database type.

atrol
Site Admin
Posts: 7658
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: Unable to Upgrade

Post by atrol » Jun 05, 2018 1:31 am

Set database type to mysqli in your config_inc.php
Please use Search before posting and read the Manual

wdolson
Posts: 22
Joined: Jan 28, 2008 6:15 am

Re: Unable to Upgrade

Post by wdolson » Jun 05, 2018 3:51 am

I changed mysql to mysqli. In the new installation attempt it didn't appear to do anything. When I changed it with the old installation and ran check.php again, I got the report at the bottom of the page. It looks like the character set in the database got changed somehow. Do I need to change the database, or is there a setting for this in Mantis somewhere?

Checking your installation
Database Type (adodb) mysqli
Database Provider (adodb) native
Database Server Description (adodb) 5.6.39-83.1-56-log
Database Server Description (version) 5.6.39
magic_quotes_gpc
Checking Table Collation is utf8 for _bug_file_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _bug_history_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _bug_monitor_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _bug_relationship_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _bug_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _bug_tag_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _bug_text_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _bugnote_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _bugnote_text_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _config_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _custom_field_project_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _custom_field_string_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _custom_field_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _email_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _filters_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _news_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _project_category_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _project_file_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _project_hierarchy_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _project_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _project_user_list_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _project_version_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _sponsorship_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _tokens_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _user_pref_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _user_print_pref_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _user_profile_table....latin1_swedish_ci BAD
Checking Table Collation is utf8 for _user_table....latin1_swedish_ci BAD
PHP variable "upload_max_filesize" 104857600
PHP variable "post_max_size" 104857600
MantisBT variable "max_file_size" 500000000
Checking MantisBT upload file size is less than php BAD
There may also be settings in your web server and database that prevent you from uploading files or limit the maximum file size. See the documentation for those packages if you need more information.
Your current settings will most likely need adjustments to the PHP max_execution_time or memory_limit settings, the MySQL max_allowed_packet setting, or equivalent.
There may also be settings in your web server that prevent you from uploading files or limit the maximum file size. See the documentation for those packages if you need more information.

Post Reply