How to set email notification settings, only assignee

General discussion of Mantis.

Moderators: Developer, Contributor

Post Reply
mpa
Posts: 20
Joined: Jan 15, 2008 7:34 am

How to set email notification settings, only assignee

Post by mpa » Aug 06, 2018 6:28 am

I have tried several settings to adjust my email notification settings without any luck so far.
So the question is... is it me?

Goal;
- Only managers do recieve an email when new tickets are submitted.
- Only the person to whom a ticket is being assigned to will recieve an email, including if the assignee is filled in when submitting a new ticket.
- When a ticket gets resolved, a certain member should alway be getting notified by email. This can also be all members within an authorisation-group.

- I don't want that everyone is getting an email on new
- I don't want that everyone is getting an email when change on handler (assignee)

Technically the mail-function works just fine.

Please help how to adjust my settings.
Any help would be very appreciated.

Thanks in advanced.

Marnix

atrol
Site Admin
Posts: 7677
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: How to set email notification settings, only assignee

Post by atrol » Aug 06, 2018 7:21 am

Do you use page page Manage > Manage Configuration > E-Mail Notifications ?
If so, attach a screenshot and I will try to tell you the columns/rows you should check/uncheck.
Please use Search before posting and read the Manual

mpa
Posts: 20
Joined: Jan 15, 2008 7:34 am

Re: How to set email notification settings, only assignee

Post by mpa » Aug 06, 2018 2:46 pm

Hi Atrol,

Hereby a screendump.

Thx, Marnix
Attachments
mantis_email.jpg
mantis_email.jpg (183.17 KiB) Viewed 2372 times

atrol
Site Admin
Posts: 7677
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: How to set email notification settings, only assignee

Post by atrol » Aug 06, 2018 3:09 pm

Not that easy to help as
- your screen dump is right clipped, e.g. I can't see access level manager
- you introduced own access levels
- this is no original Mantis, e.g. there is no label "Asset type owner" in Mantis
mpa wrote:
Aug 06, 2018 6:28 am
- Only managers do recieve an email when new tickets are submitted.
- Only the person to whom a ticket is being assigned to will recieve an email, including if the assignee is filled in when submitting a new ticket.
- I don't want that everyone is getting an email on new
In row "Status Changes to new", check only in columns " User who is handling the issue" and "Manager"
mpa wrote:
Aug 06, 2018 6:28 am
- When a ticket gets resolved, a certain member should alway be getting notified by email. This can also be all members within an authorisation-group.
Check the appropriate access level in row "Status Changes to closed"
mpa wrote:
Aug 06, 2018 6:28 am
- I don't want that everyone is getting an email when change on handler (assignee)
Uncheck all boxes in row "E-mail on change of handler"
Please use Search before posting and read the Manual

mpa
Posts: 20
Joined: Jan 15, 2008 7:34 am

Re: How to set email notification settings, only assignee

Post by mpa » Aug 09, 2018 3:28 am

Hi Atrol,

Thanks for your feedback.
I made indeed some minor and textual adjustments, but technically everything is still the same.

I have set your settings like you mentioned. And set the account settings of the assignee person according attachment.

Actions:
Submitted an new ticket, not assigned to anyone. --> the person did not get an email. (I would expected it according to his personal settings.)
Openend an existing ticket, assigned to that person, --> the person did not get an email. (I would expected it according to the settings.)

So, it seems i still don't get it right......
Attachments
Schermafbeelding 2018-08-09 om 10.24.45.png
Schermafbeelding 2018-08-09 om 10.24.45.png (114.36 KiB) Viewed 2316 times
Schermafbeelding 2018-08-09 om 10.20.51.png
Schermafbeelding 2018-08-09 om 10.20.51.png (119.12 KiB) Viewed 2316 times

atrol
Site Admin
Posts: 7677
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: How to set email notification settings, only assignee

Post by atrol » Aug 10, 2018 7:14 am

You can enable email logging that find out what's happening
https://www.mantisbt.org/docs/master/en ... ig.logging
e.g. set

Code: Select all

$g_log_level = LOG_EMAIL | LOG_EMAIL_RECIPIENT;
You might also want to set $g_log_destination to log it in a separate file instead of your default PHP logs.
Please use Search before posting and read the Manual

mpa
Posts: 20
Joined: Jan 15, 2008 7:34 am

Re: How to set email notification settings, only assignee

Post by mpa » Jan 11, 2019 11:23 am

Hi Atrol,

Thanks for the feedback Atrol, but still struggling.

It seems that your personal (account) settings overrides the general settings.

So if option 'E-mail on Change of Handler' is un-checked in your personal settings, you won't receive any email when assignee has been changed. Even when the ticket is assignee to that particular person.

But if you have checked the box 'E-mail on Change of Handler', you will also receive emails which are changed to another user. And that is not what I want to accomplice. Because then the email looses its 'power'.

So, the question is; How do set the general settings and personal setting, so that a the person only receives an email when a ticket is assigned to him/her?

KR,
Marnix

atrol
Site Admin
Posts: 7677
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: How to set email notification settings, only assignee

Post by atrol » Jan 13, 2019 5:11 am

mpa wrote:
Jan 11, 2019 11:23 am
It seems that your personal (account) settings overrides the general settings.
Override is not the right explanation for it.
At first, general settings are applied, after that personal settings.
You can not override a general setting in your personal setting, e.g. you can't receive email for something where the administrator deactivated them in general settings.
mpa wrote:
Jan 11, 2019 11:23 am
So, the question is; How do set the general settings and personal setting, so that a the person only receives an email when a ticket is assigned to him/her?
Not possible by configuration.
You would have to change source code of Mantis or write a plugin to get what you want.
Please use Search before posting and read the Manual

Post Reply