View Issue Details

IDProjectCategoryView StatusLast Update
0010235mantisbtapi soappublic2010-04-28 14:44
ReportergialluAssigned Togiallu 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.1.6 
Target VersionFixed in Version1.1.7 
Summary0010235: mc_issue_attachment_add corrupts attachments
Description

The mc_issue_attachment_add method declares it wants the attachment encoded in with the base64 method:

<code>
Input:
use: encoded
namespace: http://futureware.biz/mantisconnect
encodingStyle: http://schemas.xmlsoap.org/soap/encoding/
message: mc_issue_attachment_addRequest
parts:
username: xsd:string
password: xsd:string
issue_id: xsd:integer
name: xsd:string
file_type: xsd:string
content: xsd:base64Binary
</code>

but no decoding is made before storing the actual file so it looks like "corrupted" when getting it back.

TagsNo tags attached.

Relationships

has duplicate 0011151 closedrombert Can't upload attachment to issue via soap interface 
related to 0011039 closedrombert mc_issue_attachment_get() returns garbage 

Activities

giallu

giallu

2009-03-25 19:21

reporter   ~0021191

Fixed in the 1.1 branch. I will check if the same applies to master

rombert

rombert

2010-04-28 14:44

reporter   ~0025334

This will likely get reverted in the next release, since it is incorrect. Please see http://git.mantisbt.org/?p=mantisbt.git;a=commit;h=b836b267cfc77aa516968fe05d1804743df133d7 .

Related Changesets

MantisBT: master-1.1.x 3ec64234

2009-03-23 22:23:52

giallu

Details Diff
Fix 0010235: mc_issue_attachment_add corrupts attachments Affected Issues
0010235
mod - api/soap/mc_issue_attachment_api.php Diff File

MantisBT: master 77a58dd1

2009-03-23 22:23:52

giallu

Details Diff
Fix 0010235: mc_issue_attachment_add corrupts attachments Affected Issues
0010235
mod - api/soap/mc_issue_attachment_api.php Diff File

Issue History

Date Modified Username Field Change
2009-03-20 07:36 giallu New Issue
2009-03-25 19:20 giallu Changeset attached master-1.1.x 3ec64234 =>
2009-03-25 19:21 giallu Note Added: 0021191
2009-03-25 19:21 giallu Status new => resolved
2009-03-25 19:21 giallu Fixed in Version => 1.1.7
2009-03-25 19:21 giallu Resolution open => fixed
2009-03-25 19:21 giallu Assigned To => giallu
2009-03-25 19:40 giallu Changeset attached master 77a58dd1 =>
2009-04-20 09:49 jreese Status resolved => closed
2009-10-19 11:17 vboctor Relationship added related to 0011039
2009-11-10 15:09 rombert Relationship added has duplicate 0011151
2010-04-28 14:44 rombert Note Added: 0025334