View Issue Details

IDProjectCategoryView StatusLast Update
0010449mantisbtcustomizationpublic2011-09-14 04:15
Reporteredwerk Assigned Tovboctor  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionno change required 
Product Version1.1.7 
Summary0010449: Report issue for an other reporter
Description

We are running a non-commercial helpdesk for a health care application in the Netherlands.
Regularly we receive bug reports via e-mail of telephone. It should be possible to fill is a bug report using a different reporter name.

When reporting bugs in the advanced screen (bug_report_advanced_page.php)
and when the user has the appropriate rights (70:manager, or 90:administrator)
it should be possible to pick the reporter name from a drop-down list (with all reporters/users).
It is preferable that ‘usernames’ and ‘real names’ are displayed in the drop-down list.

Additional Information

See attached file with sreendump of requested change.
Issue is known at TCM under number 1003.

TagsNo tags attached.

Relationships

duplicate of 0011615 closeddregad Select reporter while adding an issue 

Activities

2009-05-04 01:46

 

RFC_1.rtf (154,011 bytes)
cas

cas

2009-05-04 03:01

reporter   ~0021770

Already have this change available, also in the simple report screen.
Can send you the changes once back home (next week).

edwerk

edwerk

2009-05-05 09:12

reporter   ~0021776

Ok Cas, contact me, next week, so we can arrange the deal for both issues.

cas

cas

2009-05-11 03:59

reporter   ~0021801

Last edited: 2009-05-11 05:01

View 2 revisions

So how to progress?
You can send me an email via info_at_nuy_dot_info

also send copies of the following scripts:
bug_report.php
bug_report_page.php
bug_report_advanced_page.php

2009-05-14 06:50

 

10499.txt (2,905 bytes)   
in config_inc.php add the following section:
	##################################
	# Mantis Enable selecting Reporter
	##################################
	$g_select_reporter = ON;
	$g_select_reporter_threshold = UPDATER;

	
In bug_report.php add around line 47 after:
$t_bug_data->project_id			= gpc_get_int( 'project_id' );

the following code:

	if (( ON==config_get( 'select_reporter')) and ( access_has_project_level( config_get( 'select_reporter_threshold' ) ) )) {
			$t_bug_data->reporter_id		= gpc_get_int( 'reporter_id', 0 );
		}else{
			$t_bug_data->reporter_id		= auth_get_current_user_id();
	}
	
	
In bug_report_page.php add around line 90 after:
$t_changed_project		= false;

the following code:

	if (( ON==config_get( 'select_reporter')) and ( access_has_project_level( config_get( 'select_reporter_threshold' ) ) )) {

			$f_reporter_id			= gpc_get_int( 'reporter_id', 0 );
		}
		

Around line 225 after:
		<select tabindex="9" name="product_version">
			<?php print_version_option_list( $f_product_version, $t_project_id, VERSION_RELEASED ) ?>
		</select>
	</td>
</tr>
<!-- spacer -->
<tr>
<td class="spacer" colspan="2">&nbsp;</td>
</tr>
<?php
	}
?>

the following code:

<?php if ( ON==config_get( 'select_reporter')) { ?>
<!-- Select Reporter (if permissions allow) -->
<?php if ( access_has_project_level( config_get( 'select_reporter_threshold' ) ) ) { ?>
<tr <?php echo helper_alternate_class() ?>>
<!-- Reporter -->
<td class="category">
<?php echo lang_get( 'reporter' ) ?>
</td>
<td>
<select tabindex="5" name="reporter_id">
<?php print_reporter_option_list( auth_get_current_user_id(), $t_bug->project_id ) ?>
</select>
</td>
</tr>
<?php } ?>
<?php } ?>

In bug_report_advanced_page.php add around line 90 after:
	$f_handler_id			= gpc_get_int( 'handler_id', 0 );

the following code:

	if (( ON==config_get( 'select_reporter')) and ( access_has_project_level( config_get( 'select_reporter_threshold' ) ) )) {

			$f_reporter_id			= gpc_get_int( 'reporter_id', 0 );
		}
		

Around line 225 after:
<!-- Product Build -->
<tr <?php echo helper_alternate_class() ?>>
	<td class="category">
		<?php echo lang_get( 'product_build' ) ?>
	</td>
	<td>
		<input tabindex="10" type="text" name="build" size="32" maxlength="32" value="<?php echo $f_build ?>" />
	</td>
</tr>

the following code:

<?php if ( ON==config_get( 'select_reporter')) { ?>
<!-- Select Reporter (if permissions allow) -->
<?php if ( access_has_project_level( config_get( 'select_reporter_threshold' ) ) ) { ?>
<tr <?php echo helper_alternate_class() ?>>
<!-- Reporter -->
<td class="category">
<?php echo lang_get( 'reporter' ) ?>
</td>
<td>
<select tabindex="5" name="reporter_id">
<?php print_reporter_option_list( auth_get_current_user_id(), $t_bug->project_id ) ?>
</select>
</td>
</tr>
<?php } ?>
<?php } ?>
10499.txt (2,905 bytes)   
cas

cas

2009-05-14 06:51

reporter   ~0021820

For those who also need this change, attached the instructions how to do this.
Issue can be closed.

cas

cas

2011-01-17 04:07

reporter  

CustomReporter.zip (3,081 bytes)
cas

cas

2011-01-17 04:08

reporter   ~0027961

Attached a plugin which offers the same functionality for version 1.2.X
This is all there is to it.

Issue History

Date Modified Username Field Change
2009-05-04 01:46 edwerk New Issue
2009-05-04 01:46 edwerk File Added: RFC_1.rtf
2009-05-04 01:52 edwerk Sponsorship Added edwerk: US$ 100
2009-05-04 01:52 edwerk Sponsorship Total 0 => 100
2009-05-04 03:01 cas Note Added: 0021770
2009-05-05 09:12 edwerk Note Added: 0021776
2009-05-11 03:59 cas Note Added: 0021801
2009-05-11 05:01 cas Note Edited: 0021801 View Revisions
2009-05-14 06:50 cas File Added: 10499.txt
2009-05-14 06:51 cas Note Added: 0021820
2011-01-17 04:07 cas File Added: CustomReporter.zip
2011-01-17 04:08 cas Note Added: 0027961
2011-09-13 22:20 vboctor Status new => closed
2011-09-13 22:20 vboctor Assigned To => vboctor
2011-09-13 22:20 vboctor Resolution open => no change required
2011-09-14 04:15 dregad Relationship added duplicate of 0011615