View Issue Details

IDProjectCategoryView StatusLast Update
0010472mantisbtcustom fieldspublic2019-12-13 18:06
ReporterKarolinaR Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version1.1.7 
Summary0010472: Custom fields are missing separators
Description

I guess it's a side effect of 0009606 due to the fact that the line in custom_field_api.php:

$c_value=db_prepare_string( custom_field_value_to_database( $p_value, $t_type ) );

has been changed to:
$c_value = db_prepare_string( $p_value );

Missing function "custom_field_value_to_database" causes that custom fields are inserted to database in the form:
"3.0|3.1|3.2|3.3"
instead of:
"|3.0|3.1|3.2|3.3|"
(pipes in the beginning and at th end are missing)

This causes problems with the filtering of the custom fields.

Steps To Reproduce
  1. Insert a custom field (checkbox) with value: 3.0|3.1|3.2|3.3|3.4

  2. Add or update an issue and mark e.g. 3.0, 3.1, 3.2, 3.3

  3. Go to "view issues" and try to search/filter for entries with value "3.0" or "3.3" -> Result: Your entry won't be properly filtered because values "3.0" and "3.3" are not between "|".

  4. Try to search/filter for "3.1" or "3.2" -> Result: your entry will be filtered properly.

Is it a bug or is it a feature? ;-)
Regards,
Karolina

TagsNo tags attached.

Relationships

related to 0009606 closedthraxisp Custom fields not enforced. 

Activities

thraxisp

thraxisp

2009-05-19 22:54

reporter   ~0021849

The feature is really confused. The database has a mix of entries with and without leading and trailing brackets depending on when the feature was created. The best solution is probably to remove the bars, on the assumption that entries wouldn't have the same subset of strings.

KarolinaR

KarolinaR

2009-05-20 03:00

reporter   ~0021856

So you mean that instead of changing
3.0|3.1|3.1-a|3.1-b|3.2 -> |3.0|3.1|3.1-a|3.1-b|3.2|

you want to get rid of the bars like this:
3.0|3.1|3.1-a|3.1-b|3.2 -> 3.03.13.1-a3.1-b3.2
?

How do you want to solve the issue of the same subset of strings here?

BR,
Karolina

dregad

dregad

2019-12-03 10:19

developer   ~0063181

We are resolving this issue, because it was reported against an old version of MantisBT which is no longer supported, and the problem can't be reproduced in the latest version.

If the problem still exists, do not hesitate to reopen the issue.

Issue History

Date Modified Username Field Change
2009-05-08 10:10 KarolinaR New Issue
2009-05-08 10:13 jreese Relationship added related to 0009606
2009-05-08 10:13 jreese Status new => assigned
2009-05-08 10:13 jreese Assigned To => thraxisp
2009-05-19 22:54 thraxisp Note Added: 0021849
2009-05-19 22:54 thraxisp Assigned To thraxisp =>
2009-05-19 22:54 thraxisp Status assigned => feedback
2009-05-20 03:00 KarolinaR Note Added: 0021856
2019-12-03 10:19 dregad Assigned To => dregad
2019-12-03 10:19 dregad Status feedback => resolved
2019-12-03 10:19 dregad Resolution open => unable to reproduce
2019-12-03 10:19 dregad Note Added: 0063181
2019-12-13 18:06 atrol Status resolved => closed