View Issue Details

IDProjectCategoryView StatusLast Update
0011624mantisbtbugtrackerpublic2010-04-23 14:30
Reporterjreese Assigned Tojreese  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.0 
Target Version1.2.1Fixed in Version1.2.1 
Summary0011624: Updating version name in parent project does not update references in child projects
Description

When updating version names in a parent project, version references are not updated for bugs in child projects marked against the inherited versions.

Steps To Reproduce

Create parent project 1 with version A
Create child project 2
Create bug 001 in project 2 marked against inherited version A
Update version A's name to version AX
Bug 001 is not updated, and still marked against version A

TagsNo tags attached.

Relationships

related to 0005668 acknowledged "versions" of parent project should be used in subprojects. 
related to 0011641 closedjreese Updating version name in project should update issues history 

Activities

jreese

jreese

2010-03-06 12:21

reporter   ~0024663

Fix committed to 1.2.x and master branches.

Related Changesets

MantisBT: master-1.2.x 402d8972

2010-03-06 17:05:51

jreese

Details Diff
Fix 0011624: Update version refs in child projects

When updating version names, we need to properly cascade those changes
to child projects that are using the inherited version names. This can
potentially cause an issue with child projects that have a version with
the same name as the parent project, but I believe this mechanism better
handles the user's intent, and prevents sites from "breaking" with the
new version inheritance feature.

A better solution would be to fix versions so that they are referenced
by unique IDs everywhere, similar to how categories were upgraded to use
IDs instead of duplicating the name everywhere. However, that solution
would not be considered within the scope of 1.2 due to schema changes
necessary for such a change.

Also, the project hierarchy was updated slightly to allow the version
API to access a full list of subprojects, including disabled projects.
Affected Issues
0011624
mod - core/project_hierarchy_api.php Diff File
mod - core/version_api.php Diff File

MantisBT: master fc5cb097

2010-03-06 17:05:51

jreese

Details Diff
Fix 0011624: Update version refs in child projects

When updating version names, we need to properly cascade those changes
to child projects that are using the inherited version names. This can
potentially cause an issue with child projects that have a version with
the same name as the parent project, but I believe this mechanism better
handles the user's intent, and prevents sites from "breaking" with the
new version inheritance feature.

A better solution would be to fix versions so that they are referenced
by unique IDs everywhere, similar to how categories were upgraded to use
IDs instead of duplicating the name everywhere. However, that solution
would not be considered within the scope of 1.2 due to schema changes
necessary for such a change.

Also, the project hierarchy was updated slightly to allow the version
API to access a full list of subprojects, including disabled projects.
Affected Issues
0011624
mod - core/version_api.php Diff File
mod - core/project_hierarchy_api.php Diff File

Issue History

Date Modified Username Field Change
2010-03-06 11:29 jreese New Issue
2010-03-06 11:29 jreese Status new => assigned
2010-03-06 11:29 jreese Assigned To => jreese
2010-03-06 12:20 jreese Resolution open => fixed
2010-03-06 12:20 jreese Fixed in Version => 1.3.0-beta.1
2010-03-06 12:20 jreese Changeset attached master-1.2.x 402d8972 =>
2010-03-06 12:20 jreese Changeset attached master fc5cb097 =>
2010-03-06 12:21 jreese Note Added: 0024663
2010-03-06 12:21 jreese Status assigned => resolved
2010-03-06 12:21 jreese Fixed in Version 1.3.0-beta.1 => 1.2.2
2010-03-06 15:42 dhx Relationship added related to 0005668
2010-03-10 13:23 Bithunter Issue cloned: 0011641
2010-03-10 13:23 Bithunter Relationship added related to 0011641
2010-04-23 14:30 jreese Status resolved => closed