View Issue Details

IDProjectCategoryView StatusLast Update
0012349mantisbtsignuppublic2011-08-05 02:25
Reporterelias Assigned Toatrol  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
Product Version1.1.6 
Summary0012349: A reporter must be able to update his own issue (status, assigned, all details...) while not being to update others' issues
Description

A reporter cannot update his own issue (I mean an issue that he reported). I could use the "Updater" access level but I only want the reporter to be able to update his own issues (as well as assign them to himself). In my case, this is how it should work.

Any workaround possible in Mantis to do this?
In short:

  • A reporter must be able to update his own issue in any way: he is owner of his issue
  • A reporter cannot update others' issues but can add notes
TagsNo tags attached.

Relationships

duplicate of 0008141 acknowledged Issue reporters should be able to update their own issues 

Activities

elias

elias

2010-09-15 06:07

reporter   ~0026717

Just additional note in case description was not very clear: in fact I am seeking to provide a certain access level the rights that the developer access level has but to restrict them on your own declared issues. I cannot use the developer access because this one can modify others issues which i don't want.

Issue History

Date Modified Username Field Change
2010-09-15 05:54 elias New Issue
2010-09-15 06:07 elias Note Added: 0026717
2010-09-15 06:15 atrol Relationship added duplicate of 0008141
2010-09-15 06:15 atrol Status new => resolved
2010-09-15 06:15 atrol Resolution open => duplicate
2010-09-15 06:15 atrol Assigned To => atrol
2011-08-05 02:25 atrol Status resolved => closed