View Issue Details

IDProjectCategoryView StatusLast Update
0013129mantisbthtmlpublic2011-08-05 02:45
Reportertk Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version1.2.5 
Summary0013129: firefox 3.5 and later cannot handle mantis put into a frame
Description

I've embedded mantis into a frameset as is any page of our intranet (so each page has almost the same layout).
When using IE 7, konqueror 4.3.5, or firefox 2.0.0.x this is no problem -- the mantis display is correctly built up in the destination frame.

Later versions of firefox (I tested 3.5.x and 5.0) appear to have problems with that construction -- the destination frame is blank (without output) although index.php is processed.

For a stripped down frameset example cf. the steps to reproduce.

Steps To Reproduce

<pre>
<HTML>
<HEAD>
<TITLE>TEST/TITLE>
</HEAD>
<frameset rows="500,*" frameborder=0 border=0>
<FRAME NAME="text" SRC="./index.php" frameborder=0>
</frameset>
</HTML>
</pre>

TagsNo tags attached.

Relationships

duplicate of 0012165 acknowledged Allow mantis to be loaded in an iframe 

Activities

atrol

atrol

2011-07-08 03:13

developer   ~0029129

Last edited: 2011-07-08 03:15

View 2 revisions

See duplicate 0012165 and http://www.mantisbt.org/blog/?p=102 for a workaround

Issue History

Date Modified Username Field Change
2011-07-08 02:25 tk New Issue
2011-07-08 03:13 atrol Note Added: 0029129
2011-07-08 03:13 atrol Relationship added duplicate of 0012165
2011-07-08 03:13 atrol Status new => resolved
2011-07-08 03:13 atrol Resolution open => duplicate
2011-07-08 03:13 atrol Assigned To => atrol
2011-07-08 03:15 atrol Note Edited: 0029129 View Revisions
2011-08-05 02:45 atrol Status resolved => closed