View Issue Details

IDProjectCategoryView StatusLast Update
0013358mantisbtbugtrackerpublic2011-10-09 05:37
Reportercsilbernagel Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Summary0013358: Resolved items showing up in the Unassigned view
Description

Recently one of our developers marked several bugs as fixed without ever having assigned them to someone. These items still show up in the unassigned screen. Is this a known issue? While technically correct, I'd like to see the "resolved" flag override the "unassigned" one in this view, because if it's been fixed I don't want to see it.

TagsNo tags attached.

Relationships

duplicate of 0007840 acknowledged Customizable 'my view' page 

Activities

atrol

atrol

2011-09-30 05:13

developer   ~0029890

I don't think it's a bug but a feature request which is covered by 0007840

dregad

dregad

2011-09-30 10:13

developer   ~0029897

csilbernagel, as you rightly pointed out the behavior you described is technically correct.

Furthermore I believe it is by design, as all resolved issues should be assigned to the person who fixed them. This assumption is supported by the fact that Mantis always sets the assignee to the current user when you resolve issues using the "change status to" or from the view issues page (even if you pick "blank" from the selection list).

The way the filter now works allows you to quickly identify resolved+unassigned issues and assign them, at which point they will no longer show up. Alternatively if you change status to "Closed" they will also disappear from the list.

@atrol - not sure this is really linked 0007840 but that's another story.

atrol

atrol

2011-09-30 11:18

developer   ~0029902

Last edited: 2011-09-30 11:22

View 2 revisions

I thought with the availibility of 0007840 csilbernagel can use an advanced filter (all "Resolution" != fixed && "Assigned to" = NULL && all "Status" < resolved) to get the result he wants.

dregad

dregad

2011-09-30 11:32

developer   ~0029903

@atrol - you're right.

Issue History

Date Modified Username Field Change
2011-09-29 19:00 csilbernagel New Issue
2011-09-30 05:13 atrol Note Added: 0029890
2011-09-30 05:13 atrol Relationship added duplicate of 0007840
2011-09-30 05:13 atrol Status new => resolved
2011-09-30 05:13 atrol Resolution open => duplicate
2011-09-30 05:13 atrol Assigned To => atrol
2011-09-30 10:13 dregad Note Added: 0029897
2011-09-30 11:18 atrol Note Added: 0029902
2011-09-30 11:22 atrol Note Edited: 0029902 View Revisions
2011-09-30 11:32 dregad Note Added: 0029903
2011-10-09 05:37 atrol Status resolved => closed