View Issue Details

IDProjectCategoryView StatusLast Update
0001344mantisbtinstallationpublic2008-08-12 09:35
Reporterepu Assigned Tograngeway  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionno change required 
Summary0001344: mantis install is not automated
Description

The install process is not automated. A beginning Mantis user needs to configure mySQL and Mantis manually.
To simplify the installation process for the end user, reduce the size of the readme / install documentation, and increase one of Mantis' main advantages (fast and simple to install), use PHP scripts to automate the install and upgrade paths.

Additional Information

Frequently when choosing among freeBSD software packages, I choose the most simple install, and the least reading required. Mantis is already simple to install compared to Bugzilla.

TagsNo tags attached.

Relationships

child of 0004181 closed Features in Mantis 1.1 release 

Activities

vapula

vapula

2002-08-22 04:24

reporter   ~0003155

To resume, what can be automated is the database filling. The steps that make the admin copy the files to the web repository, and to create a DB account for mantis cannot be automated through Mantisbt.

What is possible is a single (or few) page(s) to configure DB access (server, user, pass, database name), then fill in the base and set default.

epu

epu

2004-05-12 19:20

reporter   ~0005490

selection of the web repository path can be automated (browse to install path).
db account creation can be assisted/automated as you suggest.

Matt_wc

Matt_wc

2005-01-29 00:00

reporter   ~0009133

A great script would be to guide the user in setting up all (or a good sub-set) of the options in the config-inc.php file.

Once finished, the script would generate the file, then run the setup SQL statements.

Thus all a user needs to do is upload, unpack, create the DB, and run the script.

collectivedc

collectivedc

2005-01-31 16:18

reporter   ~0009154

Take a look at Moodle (www.moodle.org) for a very well implemented install routine.

grangeway

grangeway

2007-11-11 14:07

reporter   ~0016161

Thank you for taking the time to report a problem with mantis.

The newest releases of mantis do have an install.php routine that automatically runs. Please report suggestions/improvements to this new routine.

Since this problem report was originally made, a number of releases have occurred.
It appears that this issue has either been fixed, or may not be a relevant report for the current release.

Unfortunately you are not using the latest version and the problem might already be fixed. Please download the latest release from http://www.mantisbt.org/download.php

If you are able to reproduce this bug in the current release, or have some more information on how this feature could be improved in the current release. Please either change the mantis version on this bug report
to the version you tested and change the status back to "Open", or open a new issue report wit more information.

Again, thank you for your continued support and report.
Paul

Issue History

Date Modified Username Field Change
2004-05-12 19:20 epu Note Added: 0005490
2004-07-23 19:26 grangeway Relationship added child of 0004181
2004-08-07 11:04 jlatour Status new => confirmed
2004-08-07 11:06 jlatour Status confirmed => acknowledged
2005-01-29 00:00 Matt_wc Note Added: 0009133
2005-01-31 16:18 collectivedc Note Added: 0009154
2007-11-11 14:07 grangeway Status acknowledged => resolved
2007-11-11 14:07 grangeway Resolution open => no change required
2007-11-11 14:07 grangeway Assigned To => grangeway
2007-11-11 14:07 grangeway Note Added: 0016161
2008-08-12 09:35 grangeway Status resolved => closed