View Issue Details

IDProjectCategoryView StatusLast Update
0015741mantisbtcustomizationpublic2013-04-21 04:49
ReporterHeikoSL Assigned Toatrol  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
Product Version1.2.14 
Summary0015741: my_view_page.php cannot be customized
Description

Some of our mantis users want to have more information on my_view_page.php, e.g the name of the assigned user. (screenshot shows this - in german)

There is no way to customize the my_view_inc.page that does the output.

Additional Information

I've developed a small patch that tries to load a custom_my_view_inc.php if it exists. If not, it loads my_view_inc.php .

https://github.com/mantisbt/mantisbt/pull/80

TagsNo tags attached.

Relationships

duplicate of 0007840 acknowledged Customizable 'my view' page 

Activities

HeikoSL

HeikoSL

2013-04-10 07:48

reporter  

atrol

atrol

2013-04-10 08:40

developer   ~0036563

Thanks for your contribution.

I agree that we should have some more options to customize the "My View" page.
There are already some open feature requests for it.

IMO the way you want it is not the way it should be in product.

You can add your own "My View" page by setting $g_main_menu_custom_options.

What we ware missing at the moment is a configuration option to hide the original "My View" page.
Something like $g_my_view_view_threshold = NOBODY;

Let me know your thoughts.

HeikoSL

HeikoSL

2013-04-10 10:26

reporter   ~0036564

OK, that's what I didn't knew; using the $g_main_menu_custom_options sounds good to me.

Some things are:

  • you cannot hide the original my_view_page and
  • it's not possible to replace the original menu link with custom menu link, to let it appear in the same order)

But I have another idea:

Maybe it would be a possible way to add an chained event hook in html_api.php just before the $t_menu_options array implodes the menu (row ~862).

Then a plugin could analyze the menu options and do many things like sorting, adding/deleting, renaming of menu options.
The amount of work one has to do, to implement a custom my view page would be a bit higher, caused by plugin structures overhead. But I think this is a very flexible way and also easy to implement in mantis.

What do you think of this?

atrol

atrol

2013-04-11 08:26

developer   ~0036572

Then a plugin could analyze the menu options and do many things like sorting, adding/deleting, renaming of menu options.

I wonder how a plugin could be able to analyze menu options which are complete unknown to the plugin.
This would require additional meta data.

Are you aware of the existing events EVENT_MENU_MAIN_FRONT and EVENT_MENU_MAIN ?

HeikoSL

HeikoSL

2013-04-11 11:33

reporter   ~0036574

I wonder if I have correctly understood the meaning of plugins: isn't it allowed to create dependencies to the current system?

Of course a plugin knows nothing about the menu, that is build in an environment depending on config, user rights, etc.
But the set of possible menu items is limited. All standard menu items are in html_api.
Why not let the plugin know these items by coding them in (this the dependency i ment before); custom menu options could be loaded from within the plugin.
It would be possible to identify the links using the href attribute and compare them against the menu items in the plugin then.
The metadata would not exist in the mantis root but in the plugin.

I am aware of the existing events EVENT_MENU_MAIN_FRONT and EVENT_MENU_MAIN, but both are EVENT_TYPE_DEFAULT. So I cannot use them to add a menu option.
And they are fired before all menu options have been appended to the menu array.

By writing this, I realize that building the menu is quite complex...

atrol

atrol

2013-04-11 11:53

developer   ~0036575

Adding a menu entry using a plugin and the event EVENT_MENU_MAIN is quite easy.
See how it works e.g. for the ManTweet link on our own instance.

https://github.com/mantisbt-plugins/mantweet/blob/master/ManTweet.php#L153

I will close this issue as
a) your feature request is covered by other existing issues and
b) this is not the right place for such kind of discussions.

Do you agree?

Please use the forums, the mantisbt-help mailing list or IRC to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

HeikoSL

HeikoSL

2013-04-11 11:56

reporter   ~0036576

Yes, it's ok. Please close it.

Issue History

Date Modified Username Field Change
2013-04-10 07:48 HeikoSL New Issue
2013-04-10 07:48 HeikoSL File Added: MantisBT_AssignedTo_on_my_view_page.png
2013-04-10 08:40 atrol Note Added: 0036563
2013-04-10 08:40 atrol Status new => feedback
2013-04-10 10:26 HeikoSL Note Added: 0036564
2013-04-10 10:26 HeikoSL Status feedback => new
2013-04-11 08:26 atrol Note Added: 0036572
2013-04-11 08:26 atrol Status new => feedback
2013-04-11 11:33 HeikoSL Note Added: 0036574
2013-04-11 11:33 HeikoSL Status feedback => new
2013-04-11 11:53 atrol Note Added: 0036575
2013-04-11 11:53 atrol Status new => feedback
2013-04-11 11:56 HeikoSL Note Added: 0036576
2013-04-11 11:56 HeikoSL Status feedback => new
2013-04-11 17:50 atrol Relationship added duplicate of 0007840
2013-04-11 17:50 atrol Status new => resolved
2013-04-11 17:50 atrol Resolution open => duplicate
2013-04-11 17:50 atrol Assigned To => atrol
2013-04-21 04:49 atrol Status resolved => closed