View Issue Details

IDProjectCategoryView StatusLast Update
0015889mantisbtadministrationpublic2015-03-02 08:04
Reporterdavid_stephensen Assigned Todregad  
PrioritynormalSeverityminorReproducibilityhave not tried
Status acknowledgedResolutionreopened 
Product Version1.2.15 
Summary0015889: Redirect to default page after password reset
Description

Confusion after password reset

Our problem is as follows:

  1. A user needs a password reset, so we send him one
  2. The user gets the email, follows the link
  3. Mantis displays the Edit Account page which has fields for the new password
  4. User enters the new password and chooses Update
  5. Mantis accepts the new password and displays the login page
  6. User logs in with new password
  7. Mantis displays the Edit Account page which has fields for the new password
  8. User thinks he is in a loop of having to enter a new password and may go through this several times
  9. User asks for help
  10. We spend time explaining that he doesn't need to change his password again and that he can just choose any Mantis menu item and apologising for the confusion

Is there some way we can get Mantis to go to some other page like My View after a password reset?

Steps To Reproduce

see above

TagsNo tags attached.

Relationships

related to 0007625 new Password Change goes back to password change 

Activities

dregad

dregad

2013-05-21 11:17

developer   ~0036924

Last edited: 2013-05-27 04:25

View 2 revisions

From my perspective it makes sense to return to the same page after re-login when changing a password.

Also note that Mantis clearly indicates what is happening. In your sequence

  1. Mantis displays the Edit Account page which has fields for the new password

Here, it's shown in red letters above the Edit Account form:

Your account information has been verified. The account confirmation message you have received is now invalid.
You must set a password here to allow you to log in again.

  1. User enters the new password and chooses Update

Mantis says:

Password successfully updated
Operation successful.

  1. Mantis displays the Edit Account page which has fields for the new password

You'll note that here it does NOT display any text in red. And the user has just logged in with their new password, so they should know it's valid.

Based on the above, I'm tempted to just resolve this issue as "won't fix".

Technically, the redirection can be done, by modifying <i>$t_redirect = 'account_page.php';</i> in account_update.php, to whatever page you want, but you can't selectively do this only after resetting without more complex changes to the code (i.e. passing a hidden field to account_update.php)

david_stephensen

david_stephensen

2013-05-27 00:08

reporter   ~0036981

Firstly I would like to thank you and all of the other developers who donate their time to make MantisBT the great application that it is.

Unfortunately not every user of MantisBT is literate enough to know about red frames on fields. I know MantisBT was originally designed for software developers and of course this would not be a problem for a software developer.

May I ask what is the target audience for Mantis? Is it just software developers or could it be other people as well?

We use Mantis in a steel foundry. The users are blue collar workers. We are using Mantis to manage many things in the foundry, but especially corrective and preventive action. None of our users are software developers. They are just regular guys trying to keep their heads above water in an increasingly software-driven workplace. Very few of them are experienced computer users.

I created this request after having dealt with this point of confusion a large number of times with our team members, and after having to write special explanations about it, with limited effectiveness, since they are not great readers. I even found it confusing myself the first couple of times before I realised that it was not a loop.

As a business systems and quality management consultant, MantisBT is my chosen vehicle for business quality issues due to its simplicity. So, I ask you, are we welcome in your software development world enough for you to sometimes consider our needs? Is there a vision for MantisBT to be used widely?

May I ask you to take a moment to reconsider?

dregad

dregad

2013-05-27 04:40

developer   ~0036982

I don't mean to be rude or to sound condescending, but this is not about being computer-literate, it's just about reading what's printed on the screen and using basic common-sense...

With regards to the target audience, the tool was initially developped for defect tracking in software development, but there's nothing that says it can't be used for other purposes (and you're proving that case apparently).

I agree that the current behavior may be somewhat confusing, but it is also logical (i.e. after submitting a change on a page, you return to your starting point). That said, as the requested change is not overly complicated to implement and makes sense if it can indeed reduce user confusion, we can consider this for a future version. Don't hold your breath though.

Until then, as mentioned in my earlier post, there is an easy workaround which you can implement yourself right away.

atrol

atrol

2013-05-27 05:23

developer   ~0036983

We should also consider to separate the password stuff from the other settings.
This would ease to solve other issues, e.g. 0008335 0007927

david_stephensen

david_stephensen

2013-05-27 09:22

reporter   ~0036988

Thanks for being willing to look at it again, dregad. I'm happy that you might put it on the 'to do' list. I initially misread your suggestion of the fix to change the redirection. What I now realise you were saying is that I can easily 'hard wire' the change and remember to revisit this with each MantisBT upgrade, but that to make it into an optional setting in the MantisBT UI would require some programming. Is that correct? I should be able to do this hardwiring OK. Thanks for that tip. It will save us some hassles here.

I am hoping soon to get MantisBT going in a body corporate manager's business and get an interface written that he can put on his website for clients to enter service requests. Bug trackers have enormous potential for use in business but have to be reeeeeally simple. This is why I chose MantisBT.

dregad

dregad

2013-05-27 10:24

developer   ~0036989

Is that correct?

Absolutely right.

kara

kara

2015-02-18 16:30

reporter   ~0048863

David, I would sincerely appreciate if you could write some insights gained from Mantis in a steel foundry. If you applied it in different non-software environments, I mean those, too.

o What are the tasks it is used for?
o What is the target audience in quality and quantity terms?
o Which strengths qualify its use?
o Which tool(s) did it replace, if?
o What did you gain from its use?
o What did surprise you?

(I am abusing this ticket for initiating contact with david_stephensen, right.)

david_stephensen

david_stephensen

2015-02-18 18:05

reporter   ~0048865

Hi Kara

Briefly:

  • Internal between department ordering including design work, pattern work, maintenance and documentation changes
  • Purchase requisitions
  • Corrective actions of all types including audit findings, customer rejections, internal rejections
  • Permissions for deviation
  • Safety incident investigation
  • Preventive actions for risk management
  • Audit reports with links to individual findings as needed
  • Meeting minutes with links to individual action items as needed
  • Records of having done something so it has an indelible date

Generally speaking it is going very well. There are a few frustrations, most of which could be fixed if they spent money on a plugin.

Please visit my website which has some stuff on it http://qdt.com.au

I am trying to write a training resource about using it in business.

Thanks for your interest!

david_stephensen

david_stephensen

2015-02-18 18:17

reporter   ~0048866

It replaced emails, phone calls and spreadsheets

I chose it because it was meant to be simple and had the most green in its row in the Wikipedia article

I simplified it even more through configuration

The foundry can't do without it now.

I am pleasantly surprised about how well it has taken off

We still need some more discipline with using it, but the naughty people are easy to see in the Summary and we are working on them.

david_stephensen

david_stephensen

2015-02-18 18:21

reporter   ~0048867

I'm happy for you to contact me directly through details in my website.

Issue History

Date Modified Username Field Change
2013-05-21 03:24 david_stephensen New Issue
2013-05-21 11:17 dregad Note Added: 0036924
2013-05-21 11:17 dregad Status new => resolved
2013-05-21 11:17 dregad Resolution open => won't fix
2013-05-21 11:17 dregad Assigned To => dregad
2013-05-27 00:08 david_stephensen Note Added: 0036981
2013-05-27 00:08 david_stephensen Status resolved => feedback
2013-05-27 00:08 david_stephensen Resolution won't fix => reopened
2013-05-27 04:25 dregad Note Edited: 0036924 View Revisions
2013-05-27 04:40 dregad Note Added: 0036982
2013-05-27 04:40 dregad Status feedback => acknowledged
2013-05-27 04:40 dregad Category feature => administration
2013-05-27 04:40 dregad Product Version => 1.2.15
2013-05-27 04:40 dregad Summary Confusion after password reset => Redirect to default page after password reset
2013-05-27 05:23 atrol Note Added: 0036983
2013-05-27 05:40 atrol Relationship added related to 0007625
2013-05-27 09:22 david_stephensen Note Added: 0036988
2013-05-27 10:24 dregad Note Added: 0036989
2015-02-18 16:30 kara Note Added: 0048863
2015-02-18 18:05 david_stephensen Note Added: 0048865
2015-02-18 18:17 david_stephensen Note Added: 0048866
2015-02-18 18:21 david_stephensen Note Added: 0048867
2015-03-02 08:04 vitsaadmin Issue cloned: 0019437