View Issue Details

IDProjectCategoryView StatusLast Update
0017962mantisbtuipublic2019-07-21 10:45
Reportervboctor Assigned Todregad  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version1.3.0-beta.1 
Summary0017962: Implement auto-complete for reporter field in bug_update_page
Description

We should start using some control with auto-complete + dropdown behavior in several places in MantisBT. The default jQuery provides the auto-complete behavior, though doesn't provide the dropdown on an empty text box. Our dropdowns will often need to handle name and id fields. In the user cases, we may also want to handle name, real name, and id.

jQuery UI standard auto-complete:
http://jqueryui.com/autocomplete/#custom-data

TagsNo tags attached.

Relationships

duplicate of 0025666 confirmed Replace user selection list with an autocomplete widget progressive remote search 
related to 0017944 closedvboctor Regression from 1.2.x: slow performance when editing issues 
related to 0017577 assigneddregad Improve print_user_option_list() performance 
related to 0021099 new Support auto-complete when adding user to monitor list on an issue 

Activities

dregad

dregad

2019-07-05 04:38

developer   ~0062361

This is covered by 0025666.

Issue History

Date Modified Username Field Change
2014-12-13 17:16 vboctor New Issue
2014-12-13 17:16 vboctor Issue generated from: 0017944
2014-12-13 17:16 vboctor Relationship added related to 0017944
2014-12-14 17:49 dregad Relationship added related to 0017577
2016-06-13 06:28 dregad Relationship added related to 0021099
2019-07-05 04:38 dregad Assigned To => dregad
2019-07-05 04:38 dregad Status new => resolved
2019-07-05 04:38 dregad Resolution open => duplicate
2019-07-05 04:38 dregad Note Added: 0062361
2019-07-05 04:38 dregad Relationship added duplicate of 0025666
2019-07-21 10:45 atrol Status resolved => closed