View Issue Details

IDProjectCategoryView StatusLast Update
0019839mantisbtrelationshipspublic2017-10-08 23:52
Reporteratrol Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0019839: Unnecessary data created when resolving issues as duplicate
Description

When resolving issue A as a duplicate of issue B, the users that are monitoring A are added to the monitoring list of B.
This useful feature has been introduced in 0011375.

The implementation of this feature uses function bug_monitor_copy for it, which is quite elegant at first sight, but adds unnecessary data to the database.

Not needed:

  • reporter of A is added to the monitoring list of A
  • entry to history table for it
TagsNo tags attached.

Relationships

duplicate of 0023420 closedatrol Resolving as duplicate adds reporter and handler to monitoring list 
related to 0011375 closeddhx Users that are monitoring a bug should be transferred if the bug is closed as a duplicate 

Activities

atrol

atrol

2017-10-02 16:16

developer   ~0057875

Covered by 0023420

Issue History

Date Modified Username Field Change
2015-06-14 09:48 atrol New Issue
2015-06-14 09:49 atrol Relationship added related to 0011375
2017-10-02 16:16 atrol Assigned To => atrol
2017-10-02 16:16 atrol Status new => resolved
2017-10-02 16:16 atrol Resolution open => duplicate
2017-10-02 16:16 atrol Note Added: 0057875
2017-10-02 16:16 atrol Relationship added duplicate of 0023420
2017-10-08 23:52 vboctor Status resolved => closed