View Issue Details

IDProjectCategoryView StatusLast Update
0020399Plugin - EmailReporting[All Projects] Generalpublic2016-07-22 20:03
Reporterjuan.gomezAssigned ToSL-Gundam 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformmicrosoftOSwindows serverOS Version2012
Product Version 
Target VersionFixed in Version 
Summary0020399: crash executing the plugins by taskprogrammer
Description

when I run the plugin from the server I get the following error. if I run from the webserver it works fine

Steps To Reproduce

batch file:
echo off
C:\wamp\bin\php\php5.5.12\php.exe C:\wamp\www\mantis\plugins\EmailReporting\scripts\bug_report_mail.php
exit

TagsNo tags attached.

Relationships

has duplicate 0021161 closedSL-Gundam PHP call to process emails fails with a fatal error 

Activities

juan.gomez

juan.gomez

2015-12-16 18:56

reporter  

erro_mailreport.png (31,292 bytes)
erro_mailreport.png (31,292 bytes)
juan.gomez

juan.gomez

2015-12-16 18:56

reporter  

SL-Gundam

SL-Gundam

2015-12-16 22:19

manager   ~0052133

First off please upgrade to 0.9.0 stable release - https://github.com/mantisbt-plugins/EmailReporting/releases/latest

Secondly
MantisBT 1.2.19 loads the authentication_api.php in core.php after it loads plugins
Following the stacktrace it seems to be "TriggerClose" that executes a function that is not available yet.
Based on sourcecode it seems you are not running the most recent version of TriggerClose since the stacktrace references line 301 in triggercloseapi.php while the file only has 298 lines on github

Updating TriggerClose might fix it. If it is not fixed after updating the plugin TriggerClose, please disable/remove it.

If the issue is still present after disabling/removing the plugin TriggerClose please reopen this ticket and provide another stacktrace

Issue History

Date Modified Username Field Change
2015-12-16 18:56 juan.gomez New Issue
2015-12-16 18:56 juan.gomez File Added: erro_mailreport.png
2015-12-16 18:56 juan.gomez File Added: 16-12-2015 05-36-05 p.m..png
2015-12-16 21:56 SL-Gundam Assigned To => SL-Gundam
2015-12-16 21:56 SL-Gundam Status new => assigned
2015-12-16 22:19 SL-Gundam Status assigned => resolved
2015-12-16 22:19 SL-Gundam Resolution open => fixed
2015-12-16 22:19 SL-Gundam Note Added: 0052133
2015-12-16 22:19 SL-Gundam Resolution fixed => no change required
2016-06-26 22:21 SL-Gundam Relationship added has duplicate 0021161
2016-07-22 20:03 SL-Gundam Status resolved => closed
2016-07-22 20:03 SL-Gundam Resolution no change required => fixed