View Issue Details

IDProjectCategoryView StatusLast Update
0002117mantisbtbugtrackerpublic2011-12-03 10:29
Reporter111 Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Platformx86OSWindows 2000 
Product Versionnone 
Summary0002117: default language for admin
Description

even if in config_inc.php we set

# --- language settings -----------
$g_default_language     = 'italian';

# list the choices that the users are allowed to choose
$g_language_choices_arr = array( 'italian', 'english');

the default language for "administrator" is still english, for all other users (ex. an user upgraded to admin) is italian.

TagsNo tags attached.

Relationships

child of 0004181 closed Features in Mantis 1.1 release 

Activities

reporter

reporter

2002-06-11 13:13

reporter   ~0002845

sorry, i forget: tested on the latest cvs snapshot

reporter

reporter

2002-06-11 13:46

reporter   ~0002846

resolved, set
language varchar(32) NOT NULL default 'italian',
in db_generate.sql

vboctor

vboctor

2002-06-12 15:03

manager   ~0002853

As you found out, the "administrator" is a special case because it is already added in an empty database with language set in preferences as "english". One way to fix this is to support a language named "<default>". So if a user like administrator has the language set as default, the default language is used from config_inc.php.

jlatour

jlatour

2004-08-09 05:03

reporter   ~0006852

Now that we have language detection, I suppose we could make the default language 'auto', or whatever the string is.

dregad

dregad

2011-11-26 13:52

developer   ~0030343

This issue cannot be reproduced in recent versions of Mantis (>= 1.1.0)

Issue History

Date Modified Username Field Change
2004-08-09 05:03 jlatour Note Added: 0006852
2004-08-09 05:03 jlatour Reporter reporter => 111
2004-08-09 05:03 jlatour Status new => confirmed
2004-08-09 05:07 jlatour Relationship added child of 0004181
2011-11-26 13:52 dregad Note Added: 0030343
2011-11-26 13:52 dregad Status confirmed => resolved
2011-11-26 13:52 dregad Resolution open => unable to reproduce
2011-11-26 13:52 dregad Assigned To => dregad
2011-12-03 10:29 atrol Status resolved => closed