View Issue Details

IDProjectCategoryView StatusLast Update
0021284mantisbtinstallationpublic2018-11-11 17:17
Reporterklaus-donnertAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.0 
Target Version2.19.0Fixed in Version2.19.0 
Summary0021284: memory_limit test fails when memory_limit is set to -1
Description

A memory_limit of -1 is unlimited.

Test Fails:

memory_limit php.ini directive is at least equal to the post_max_size directive
The current value of the memory_limit directive is -1 bytes. This value needs to be at least equal to the post_max_size directive value of 10485760 bytes.

Steps To Reproduce

Set php.ini memory_limit set to -1

clean install mantisbt

run /admin/check/index.php

TagsNo tags attached.

Activities

klaus-donnert

klaus-donnert

2016-07-13 16:53

reporter   ~0053596

I do not have an easy work-around on my server because php was compiled without --enable-memory-limit.

atrol

atrol

2018-11-05 03:01

developer   ~0060922

PR https://github.com/mantisbt/mantisbt/pull/1406

Related Changesets

MantisBT: master ec296308

2018-11-05 02:33:40

atrol

Details Diff
Fix check for PHP memory_limit setting

Allow -1 (unlimited) as a valid setting for memory_limit
http://php.net/manual/en/ini.core.php#ini.memory-limit

Fixes 0021284
Affected Issues
0021284
mod - admin/check/check_php_inc.php Diff File

Issue History

Date Modified Username Field Change
2016-07-13 16:32 klaus-donnert New Issue
2016-07-13 16:53 klaus-donnert Note Added: 0053596
2016-07-14 01:31 atrol Status new => confirmed
2018-11-05 03:00 atrol Assigned To => atrol
2018-11-05 03:00 atrol Status confirmed => assigned
2018-11-05 03:01 atrol Target Version => 2.19.0
2018-11-05 03:01 atrol Additional Information Updated View Revisions
2018-11-05 03:01 atrol Note Added: 0060922
2018-11-11 17:17 atrol Changeset attached => MantisBT master ec296308
2018-11-11 17:17 atrol Status assigned => resolved
2018-11-11 17:17 atrol Resolution open => fixed
2018-11-11 17:17 atrol Fixed in Version => 2.19.0