View Issue Details

IDProjectCategoryView StatusLast Update
0021393mantisbtadministrationpublic2018-05-31 14:45
ReporterkerwinchenAssigned Tovboctor 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.0 
Target Version2.9.1Fixed in Version2.9.1 
Summary0021393: When disable "Update an issue", then "Assign to" become access deined.
Description

I just want to hide "Edit" button.

Role: Developer
Config: "Update an issue" ==> disable
"Assign an issue" ==> enable

The config is work fine at ver 1.2.19

Tagsmantishub

Relationships

related to 0022093 closedvboctor Reporter can´t change status of a bug 
has duplicate 0023201 closedatrol unable to reassign without "update an issue" rigth 
has duplicate 0023424 closedatrol Workflow Threshold - can't allow assignment or change status without edit permission 
related to 0024512 closedatrol Can't reopen resolved bug from another reporter 

Activities

raymondf

raymondf

2017-10-13 12:24

reporter   ~0057957

For us this is also major, because we use MantisBT to manage AT bug communications with our supplier. And we don't want a developer to change the original content.

Somehow this bug also has a relationship with 0022093. The fix described there (ver 2.7.0, bug_update.php, line 158), fixed also this issue.
Note: so 0022093 was also a major for us...

vboctor

vboctor

2017-12-12 23:35

manager   ~0058381

PR: https://github.com/mantisbt/mantisbt/pull/1254

Related Changesets

MantisBT: master-2.9 bf1f02f7

2017-12-12 23:24:40

vboctor

Details Diff
Fix access checks for assign and change status

- Users should be able to assign issues even if they can’t update issues.
- Users should be able to change status even if they can’t update issues.

Fixes 0021393, 0022093
Affected Issues
0021393, 0022093
mod - bug_update.php Diff File

Issue History

Date Modified Username Field Change
2016-07-19 23:17 kerwinchen New Issue
2017-08-09 07:54 atrol Relationship added has duplicate 0023201
2017-10-02 12:45 atrol Relationship added has duplicate 0023424
2017-10-13 12:24 raymondf Note Added: 0057957
2017-10-13 13:03 atrol Relationship added related to 0022093
2017-12-12 22:00 vboctor Tag Attached: mantishub
2017-12-12 23:20 vboctor Assigned To => vboctor
2017-12-12 23:20 vboctor Status new => assigned
2017-12-12 23:20 vboctor Target Version => 2.9.1
2017-12-12 23:35 vboctor Note Added: 0058381
2017-12-23 00:34 vboctor Changeset attached => MantisBT master-2.9 bf1f02f7
2017-12-23 00:34 vboctor Status assigned => resolved
2017-12-23 00:34 vboctor Resolution open => fixed
2017-12-23 04:33 atrol Fixed in Version => 2.9.1
2017-12-30 18:36 vboctor Status resolved => closed
2018-05-31 14:45 atrol Relationship added related to 0024512