View Issue Details

IDProjectCategoryView StatusLast Update
0021843mantisbtattachmentspublic2017-03-07 12:26
Reportermcmo Assigned Tovboctor  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version2.0.0-rc.1 
Summary0021843: Attachment dropzone missing from notes when the note is private
Description

when a note is private, the dropzone does not appear.
This is working correctly in 1.3.2 and 2.0.0.b3
probably related to issue 0021806

Steps To Reproduce

view an issue
check the "private" checkbox in the add note zone

TagsNo tags attached.

Relationships

related to 0021806 closedvboctor Attachment dropzone missing from notes when user doesn't have access to set view state 
related to 0009802 closedvboctor Support attachments associated with private notes 
has duplicate 0022491 closeddregad Add Note - confusing behavior after View Status toggle is selected 

Activities

mcmo

mcmo

2016-11-02 12:43

reporter  

mcmo

mcmo

2016-11-02 12:43

reporter  

vboctor

vboctor

2016-11-02 22:02

manager   ~0054386

This is by design, the reason is that we don't support the concept of private attachments as of now. So it is mis-leading to accept a private note with an attachment, then have the note as private and the attachment as public. So we have optimized for avoiding data disclosure here. In the future, we are planning to add such feature.

dregad

dregad

2016-11-04 09:30

developer   ~0054410

@vboctor based on your feedback I would suggest we close this in favor of 0009802 what do you think ?

vboctor

vboctor

2016-11-08 11:44

manager   ~0054473

Resolving as 'no change required' in favor of 0009802.