View Issue Details

IDProjectCategoryView StatusLast Update
0021867mantisbtfilterspublic2018-03-31 19:58
ReportercproensaAssigned Tocproensa 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3.4 
Target Version2.13.0Fixed in Version2.13.0 
Summary0021867: Filter filed "relationships" resets its value when "duplicate of" is selected
Description

When setting the filed "relationships" to "duplicate of", the filter value is reset.
This relationship internally has a value of 0, and is mapped into "any" instead.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master 88025e8c

2017-10-23 03:29:28

cproensa


Committer: dregad Details Diff
Fix display of relationship 0

Relation "duplicate of" has id value 0, and is being converted to "any"
in the filter box.
The code removed here does not make sense now as filters have a better
default and validation.

Fixes: 0021867
Affected Issues
0021867
mod - core/filter_form_api.php Diff File

Issue History

Date Modified Username Field Change
2016-11-06 05:26 cproensa New Issue
2017-10-23 03:32 cproensa Assigned To => cproensa
2017-10-23 03:32 cproensa Status new => assigned
2018-03-05 04:19 dregad Changeset attached => MantisBT master 88025e8c
2018-03-05 04:19 cproensa Status assigned => resolved
2018-03-05 04:19 cproensa Resolution open => fixed
2018-03-05 04:19 cproensa Fixed in Version => 2.13.0
2018-03-05 04:26 atrol Target Version => 2.13.0
2018-03-31 19:58 vboctor Status resolved => closed