View Issue Details

IDProjectCategoryView StatusLast Update
0022187mantisbtcustomizationpublic2019-01-09 18:47
ReporterKunda Assigned To 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status acknowledgedResolutionopen 
Product Version1.3.4 
Summary0022187: Ability to add placeholder text in the bug_report_page.php
Description

Ref: Downstream issue: http://freecadweb.org/tracker/view.php?id=2846
Asking if it's possible to make customized placeholder text that:
1) appears in the textfield when the page is loaded
2) will disappear once the user starts entering their information in said text field
I've attached a mockup of what I'm trying to achieve.

The concern is that such customizations are not possible and we'd need to manually modify and maintain the mantis source with each update.

TagsNo tags attached.

Relationships

related to 0014695 closedatrol Ability to add a default summary or description 

Activities

Kunda

Kunda

2017-01-12 18:40

reporter  

vboctor

vboctor

2017-01-14 00:31

manager   ~0055115

The way to achieve this is to have configuration opens that can be set in config_inc.php or the database (per project) that end up in the HTML place holder text, which provides the desired behavior automatically. Contributions via Github Pull Requests are welcome.

Kunda

Kunda

2017-01-14 17:29

reporter   ~0055125

Thanks @vboctor
Follow up question: Can you give an example?

vboctor

vboctor

2017-01-14 17:40

manager   ~0055127

Here is an example of placeholder usage:
http://www.w3schools.com/tags/att_input_placeholder.asp

Kunda

Kunda

2017-01-14 17:57

reporter   ~0055129

@vboctor would I use the patch template that jehanns uses in 0014695 (attached here: http://mantisbt.org/bugs/file_download.php?file_id=4051&type=bug) but swap in HTML input markup?

Kunda

Kunda

2017-01-17 07:49

reporter   ~0055185

@vboctor How can i add the following to be executed when bug_report_page.php loads ?
<code>$('textarea[name*="steps_to_reproduce"]').attr('placeholder', 'Please produce a step-by-step...')</code>

Issue History

Date Modified Username Field Change
2017-01-12 18:40 Kunda New Issue
2017-01-12 18:40 Kunda File Added: FC-Mantis-Bug-Reporting-Template.png
2017-01-13 02:30 atrol Assigned To => atrol
2017-01-13 02:30 atrol Status new => resolved
2017-01-13 02:30 atrol Resolution open => duplicate
2017-01-13 02:30 atrol Relationship added duplicate of 0014695
2017-01-13 16:01 atrol Assigned To atrol =>
2017-01-13 16:01 atrol Severity minor => feature
2017-01-13 16:01 atrol Status resolved => acknowledged
2017-01-13 16:01 atrol Resolution duplicate => open
2017-01-13 16:02 atrol Relationship replaced related to 0014695
2017-01-14 00:31 vboctor Note Added: 0055115
2017-01-14 17:29 Kunda Note Added: 0055125
2017-01-14 17:40 vboctor Note Added: 0055127
2017-01-14 17:57 Kunda Note Added: 0055129
2017-01-17 07:49 Kunda Note Added: 0055185