View Issue Details

IDProjectCategoryView StatusLast Update
0022346mantisbtuipublic2017-02-10 07:22
Reporterj_schultz Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status newResolutionreopened 
Product Version2.1.0 
Summary0022346: Highlight the linked-to issue
Description

When following the link to a bug note (here is a random example), the browser directly jumps to that bug note. However, since the introduction of Modern UI, there is is a black bar at the top of the issue tracker that is always visible and partly obfuscates the linked note. This makes it difficult to understand which note was being linked.

Two proposed fixes:

  1. Ensure that the bug note is not covered by the black bar. I am not sure if this is possible without JavaScript.
  2. Somehow highlight the linked-to issue using the CSS pseudo-class :target. For example, the background could be changed to yellow. This would be a good idea regardless of the reported issue, because on a big screen and a short bug page, it might not be the case that the browser can scroll the linked-to bug note to the top of the screen anyway.
TagsNo tags attached.

Relationships

related to 0021675 assignedsyncguru Incorrect positioning of "View Issue Details" when recalled from "Direct link to note" 

Activities

j_schultz

j_schultz

2017-02-08 13:17

reporter   ~0055586

Thanks for pointing at the duplicate. Since suggestion 2 in my bug description is somewhat independent from the original issue (no matter if the top bar hides the linked note or not, it would be nice if it was highlighted) and might be easier to implement than a proper bugfix, maybe this issue could be reopened and renamed to "Highlight linked bug notes"?

Issue History

Date Modified Username Field Change
2017-02-08 11:57 j_schultz New Issue
2017-02-08 13:01 atrol Assigned To => atrol
2017-02-08 13:01 atrol Status new => resolved
2017-02-08 13:01 atrol Resolution open => duplicate
2017-02-08 13:01 atrol Relationship added duplicate of 0021675
2017-02-08 13:17 j_schultz Note Added: 0055586
2017-02-10 07:22 atrol Assigned To atrol =>
2017-02-10 07:22 atrol Severity minor => feature
2017-02-10 07:22 atrol Status resolved => new
2017-02-10 07:22 atrol Resolution duplicate => reopened
2017-02-10 07:22 atrol Summary Top bar hides part of linked note => Highlight the linked-to issue
2017-02-10 07:22 atrol Relationship replaced related to 0021675