View Issue Details

IDProjectCategoryView StatusLast Update
0022500mantisbtdb mssqlpublic2017-03-19 16:03
Reportergfernandez Assigned Toatrol  
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionduplicate 
PlatformwindowsOSWINDOWS SERVER 2012R2OS Version64
Product Version2.0.0 
Summary0022500: Problems with attachments stored in database when using MSSQL
Description

Realice la instalación del mantis 2.0.0 en un windows server 2012 r2 con DB SQL, el problema es cuando realizo la creación de una incidencia subo el archivo (jpg., png., docx., pdf., etc) con normalidad, el problema es al intentar abrir el archivo una vez descargado, pues me sale de que el archivo ha sido dañado o es demasiado grande (cabe recalcar que dichos documentos no llegan ni a 1 Mb).
Estaré atento a su pronta respuesta.

Atte.
Gian Marco Fernández
Saludos.

Steps To Reproduce
  • Crear una incidencia
  • Adjuntar un documento
  • Enviar incidencia
  • Descargar documento
  • Abrirlo
Additional Information

Debo de configurar otras variables aparte de estas tres?

$g_dropzone_enabled = ON;
$g_allow_file_upload = ON;
$g_file_upload_method = DATABASE;

TagsNo tags attached.

Relationships

duplicate of 0022208 closeddregad File upload to MS-SQL not working 

Activities

gfernandez

gfernandez

2017-03-08 15:53

reporter  

gfernandez

gfernandez

2017-03-08 16:48

reporter   ~0056007

I install the mantis 2.0.0 on a Windows Server 2012 r2 with SQL DB. The problem is when I create an incidence uploap the life like jpg, png. docs and pdf. with normalily.
The problem is when i try to open the life once downloaded, because I get that the file has been damaged or is too large although these documents do not reach a 1 mb.

I will be attentive to your response

atrol

atrol

2017-03-09 06:11

developer   ~0056012

with SQL DB

Do you mean MySQL or MSSQL?

gfernandez

gfernandez

2017-03-09 08:53

reporter   ~0056015

I mean MSSQL

atrol

atrol

2017-03-09 09:09

developer   ~0056016

Sorry, I can't help as I don't use MSSQL for MantisBT.

0022208 might be the same issue.
The fix provied at 0022208:0055178 might fix the issue, but use at your own risk.

I recommend to use $g_file_upload_method = DISK; if you wanto to stay with MSSQL.
Maybe MySQL is also an option for you. MantisBT is much better supported with MySQL.

gfernandez

gfernandez

2017-03-09 09:12

reporter   ~0056017

But in earlier versions of mantis if such action could be performed.
I'll check anyway
Thanks.

atrol

atrol

2017-03-09 09:35

developer   ~0056018

I'll check anyway

Waiting for you result

gfernandez

gfernandez

2017-03-09 09:51

reporter   ~0056019

Thanks, it is correct with that incident that you attached me, I managed to find the problem, in the file database_api.php I commented on line 782 (case 'mssqlnative'), the function is:

function db_prepare_binary_string( $p_string )

https://github.com/mantisbt/mantisbt/blob/release-2.0.0/core/database_api.php#L782

thansk for your support

Issue History

Date Modified Username Field Change
2017-03-08 15:53 gfernandez New Issue
2017-03-08 15:53 gfernandez File Added: Adjuntar archivo en mantis.docx
2017-03-08 16:48 gfernandez Note Added: 0056007
2017-03-09 06:11 atrol Status new => feedback
2017-03-09 06:11 atrol Note Added: 0056012
2017-03-09 08:53 gfernandez Note Added: 0056015
2017-03-09 08:53 gfernandez Status feedback => new
2017-03-09 09:09 atrol Status new => feedback
2017-03-09 09:09 atrol Category customization => db mssql
2017-03-09 09:09 atrol Note Added: 0056016
2017-03-09 09:10 atrol Summary Abrir archivos adjuntados en mantis => Problems with attachments stored in database when using MSSQL
2017-03-09 09:12 gfernandez Note Added: 0056017
2017-03-09 09:12 gfernandez Status feedback => new
2017-03-09 09:35 atrol Status new => feedback
2017-03-09 09:35 atrol Note Added: 0056018
2017-03-09 09:51 gfernandez Note Added: 0056019
2017-03-09 09:51 gfernandez Status feedback => new
2017-03-09 10:02 atrol Assigned To => atrol
2017-03-09 10:02 atrol Status new => resolved
2017-03-09 10:02 atrol Resolution open => duplicate
2017-03-09 10:02 atrol Relationship added duplicate of 0022208
2017-03-19 16:03 atrol Status resolved => closed