View Issue Details

IDProjectCategoryView StatusLast Update
0022518mantisbtreportspublic2019-10-01 04:33
ReporterKunda Assigned Tocproensa  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.2.0 
Fixed in Version2.22.0 
Summary0022518: Graph too large to fit in browser viewport
Description

When viewing MantisGraph/issues_trend_graph.php it's not possible to actually fit the whole thing in my browser (FF v52.0 (64-bit) or Chrome v57.0.2987.98 (64-bit). I tried zooming in and out to see if that would change the scale but it doesn't help.

It presents issues when trying to read it and taking screenshots.

Steps To Reproduce

See attached screenshot

TagsNo tags attached.

Activities

Kunda

Kunda

2017-03-14 22:43

reporter  

Kunda

Kunda

2019-09-29 08:54

reporter   ~0062924

This issue can be closed since the graph has been redesigned (looks great)

dregad

dregad

2019-10-01 04:33

developer   ~0062933

This was most likely fixed in 2.20.0 by MantisBT master fad38bbf but I did not actually test to confirm whether that was the indeed the case.

Related Changesets

MantisBT: master fad38bbf

2019-01-07 19:35:48

cproensa


Committer: dregad Details Diff
MantisGraph, adjust width of some graphs.

Some graphs pages only display one graph. When they are displayed in the
full page width, the 5:4 aspect ratio doesn't fit in the usual screen
sizes.
Make them double wide, but keep the height, to mantain the constant fill
area similar to those pages with side by side graphs.
Affected Issues
0022518
mod - plugins/MantisGraph/core/graph_api.php Diff File
mod - plugins/MantisGraph/pages/issues_trend_graph.php Diff File
mod - plugins/MantisGraph/pages/reporter_graph.php Diff File

Issue History

Date Modified Username Field Change
2017-03-14 22:43 Kunda New Issue
2017-03-14 22:43 Kunda File Added: unable-to-see-mantisbt-issue-trend-graph.png
2017-03-15 03:40 atrol Status new => acknowledged
2017-03-15 03:40 atrol Category ui => reports
2019-09-29 08:54 Kunda Note Added: 0062924
2019-09-30 19:39 syncguru Assigned To => syncguru
2019-09-30 19:39 syncguru Status acknowledged => closed
2019-09-30 19:39 syncguru Resolution open => fixed
2019-10-01 04:33 dregad Assigned To syncguru => cproensa
2019-10-01 04:33 dregad Fixed in Version => 2.22.0
2019-10-01 04:33 dregad Additional Information Updated View Revisions
2019-10-01 04:33 dregad Changeset attached => MantisBT master fad38bbf
2019-10-01 04:33 dregad Additional Information Updated View Revisions
2019-10-01 04:33 dregad Note Added: 0062933