View Issue Details

IDProjectCategoryView StatusLast Update
0023040mantisbtupgradepublic2017-07-20 00:23
Reporterhermann901 Assigned Toatrol  
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version2.5.1 
Summary0023040: upgrade 1.x to 2.5.1
Description

DB update feiled

MSG

Post 1.0 schema changes
Connecting to database... OK
Schema step 185: AddColumnSQL ( mantis_custom_field_string_table ) - ERROR: ALTER TABLE mantis_custom_field_string_table ADD text LONGTEXT DEFAULT NULL
Duplicate column name 'text'
1 schema upgrades executed.
Failed.

TagsNo tags attached.

Activities

atrol

atrol

2017-06-21 11:03

developer   ~0057114

upgrade 1.x to 2.5.1

What means 1.x exactly?

Is there are column text in table mantis_custom_field_string_tablein the original database before you start the upgrade script?

hermann901

hermann901

2017-06-21 11:14

reporter   ~0057115

version 1.2.19 old

i bakup all data and sql

1 i remove old BT
2 i uploaded new verion
3 i run installer
4 done

hermann901

hermann901

2017-06-21 11:16

reporter   ~0057116

DB sccren

Unbenannt.PNG (197,558 bytes)   
Unbenannt.PNG (197,558 bytes)   
hermann901

hermann901

2017-06-21 11:17

reporter   ~0057117

*+ i upload my old config

atrol

atrol

2017-06-21 11:28

developer   ~0057118

There was no text field in 1.2.19, this has been introduced in 1.3.0-beta.1, see 0006626.

Did you patch 1.2.19 to use the new custom field type in 1.2.x?

hermann901

hermann901

2017-06-21 11:33

reporter   ~0057119

no

hermann901

hermann901

2017-06-21 11:45

reporter   ~0057120

i use patch 1.2.19 and update to 2.5.1

and have sql error last post

atrol

atrol

2017-06-21 11:56

developer   ~0057122

I can just repeat what I wrote before:
There was no text field in 1.2.19, this has been introduced in 1.3.0-beta.1, see 0006626.

This means that someone changed your 1.2.19 database (added text field), which is causing the problem when trying to upgrade.

You have to check, if there is any data in the text field.
You could remove the database column, if there is no data in it.
After that, the upgrade should run without the mentioned error.

In case there is data: Change file admin/schema.php
from

$g_upgrade[185] = array( 'AddColumnSQL', array( db_get_table( 'custom_field_string' ), "
    text                    XL      NULL DEFAULT NULL" ) );

to

$g_upgrade[185] = null;

hermann901,

This is not a bug or feature request for MantisBT (you are asking for help on how to deal with problems that you introduced yourself by changing the original database schema). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

hermann901

hermann901

2017-06-21 12:05

reporter   ~0057123

i change it and next error
ALTER TABLE mantis_bug_monitor_table ADD INDEX idx_bug_id (bug_id)
Duplicate key name 'idx_bug_id'

hermann901

hermann901

2017-06-21 12:25

reporter   ~0057124

thx i fixed

thx

Issue History

Date Modified Username Field Change
2017-06-21 10:47 hermann901 New Issue
2017-06-21 11:03 atrol Status new => feedback
2017-06-21 11:03 atrol Note Added: 0057114
2017-06-21 11:14 hermann901 Note Added: 0057115
2017-06-21 11:14 hermann901 Status feedback => new
2017-06-21 11:16 hermann901 File Added: Unbenannt.PNG
2017-06-21 11:16 hermann901 Note Added: 0057116
2017-06-21 11:17 hermann901 Note Added: 0057117
2017-06-21 11:28 atrol Status new => feedback
2017-06-21 11:28 atrol Note Added: 0057118
2017-06-21 11:33 hermann901 Note Added: 0057119
2017-06-21 11:33 hermann901 Status feedback => new
2017-06-21 11:45 hermann901 Note Added: 0057120
2017-06-21 11:56 atrol Assigned To => atrol
2017-06-21 11:56 atrol Status new => resolved
2017-06-21 11:56 atrol Resolution open => no change required
2017-06-21 11:56 atrol Note Added: 0057122
2017-06-21 12:05 hermann901 Note Added: 0057123
2017-06-21 12:25 hermann901 Note Added: 0057124
2017-07-01 10:02 atrol Status resolved => closed