View Issue Details

IDProjectCategoryView StatusLast Update
0023045mantisbtfeaturepublic2019-03-16 20:20
Reporter_Zamorano_Assigned Toatrol 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.1.0 
Target Version2.20.0Fixed in Version2.20.0 
Summary0023045: Usability suggestion at Report Issue screen
Description

When posting a new issue, after they have already typed some information, users tend to click on the big blue "Report new issue" button instead of "Send" button.

This happens because, depending on your screen resolution and browser zoom, the "Send" button is not visible without scrolling down

By doing so, they lose all the information already typed without no prior warning, as the "new issue" form reverts back to the empty state, cleaning all fields.

It would be great to to show a warning dialog when you're about to leave the screen, without sending the data you've already typed. Or even better, to have an additional Send button closer to the top of the screen.

Tagsmodern-ui

Relationships

has duplicate 0023055 closedatrol Reporting issue while editing report will discard your all changes 
has duplicate 0023458 closedatrol Clicking "Report Issue" deletes issue 

Activities

atrol

atrol

2017-06-29 02:09

developer   ~0057150

Some while ago I proposed to remove the Report Issuebutton in navbar, as there is the same function in side bar.
Now there is another reason to change it, as inexperienced users think that Report Issue stores the issue they started to create.

Some options

  • remove the button from navbar
  • display one more Submit Issue button at the top of the page in addition to the existong one at the bottom
  • change the label of the Report Issuebutton to Submit Issue and the functionality behind it after pushing the first time
  • display a warning if someone started entering values and tries to navigate to another page

@syncguru what do you think?

thdk

thdk

2019-02-05 04:16

reporter   ~0061407

A simple fix would be to hide the Report Issue button in the nav bar when submitting a new issue. (bug_report_page)

I hear often from my colleagues they lost their entire issue description because of that big blue button on top of the page.

atrol

atrol

2019-02-05 05:02

developer   ~0061408

Thanks @thdk I think the simple fix is good enough.

PR https://github.com/mantisbt/mantisbt/pull/1458

thdk

thdk

2019-02-05 10:06

reporter   ~0061409

@atrol I've checked your fix. (thanks for that!) but could it be done for the update page too?

atrol

atrol

2019-02-05 10:54

developer   ~0061410

@thdk please try the updated version of the fix.

thdk

thdk

2019-02-05 11:13

reporter   ~0061411

@atrol perfect! Tested both update and report page.

dregad

dregad

2019-02-06 05:36

developer   ~0061414

To be honest, I think this button is completely redundant, and we could even consider removing it completely... The same functionality is readily available with a single click on the sidebar (OK, that's 2 clicks on a phone/tablet, but on narrow screens the button is hidden anyway so it does not help there).

atrol

atrol

2019-02-06 06:45

developer   ~0061416

Last edited: 2019-02-06 06:45

View 2 revisions

To be honest, I think this button is completely redundant, and we could even consider removing it completely...

Right, I asked for it some while ago when the button has been introduced 0023045:0057150
Unfortunately I don't remember where to find the discussion and what was the reason to finally introduce it.

Meanwhile users (including myself) are used to use this button to report an issue, so removing it now will certainly end in new discussions and reports from users missing the button after upgrade.

Related Changesets

MantisBT: master 5e36221c

2019-02-05 04:55:04

atrol

Details Diff
Hide "Report Issue" button in navbar on bug_report_page

Fixes 0023045
Affected Issues
0023045
mod - core/layout_api.php Diff File

MantisBT: master d5ee146b

2019-02-05 10:50:48

atrol

Details Diff
Hide "Report Issue" button in navbar on bug_update_page

Fixes 0023045
Affected Issues
0023045
mod - core/layout_api.php Diff File

Issue History

Date Modified Username Field Change
2017-06-23 14:12 _Zamorano_ New Issue
2017-06-29 01:46 atrol Relationship added has duplicate 0023055
2017-06-29 02:05 atrol Tag Attached: modern-ui
2017-06-29 02:09 atrol Note Added: 0057150
2017-10-11 02:17 atrol Relationship added has duplicate 0023458
2019-02-05 04:16 thdk Note Added: 0061407
2019-02-05 05:00 atrol Assigned To => atrol
2019-02-05 05:00 atrol Status new => assigned
2019-02-05 05:00 atrol Target Version => 2.20.0
2019-02-05 05:02 atrol Note Added: 0061408
2019-02-05 10:06 thdk Note Added: 0061409
2019-02-05 10:54 atrol Note Added: 0061410
2019-02-05 11:13 thdk Note Added: 0061411
2019-02-06 05:36 dregad Note Added: 0061414
2019-02-06 06:45 atrol Note Added: 0061416
2019-02-06 06:45 atrol Note Edited: 0061416 View Revisions
2019-02-11 15:11 atrol Changeset attached => MantisBT master 5e36221c
2019-02-11 15:11 atrol Changeset attached => MantisBT master d5ee146b
2019-02-11 15:11 atrol Status assigned => resolved
2019-02-11 15:11 atrol Resolution open => fixed
2019-02-11 15:11 atrol Fixed in Version => 2.20.0
2019-03-16 20:20 vboctor Status resolved => closed