View Issue Details

IDProjectCategoryView StatusLast Update
0023161mantisbttimelinepublic2018-03-31 19:58
ReporterZipherAssigned Todregad 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target Version2.13.0Fixed in Version2.13.0 
Summary0023161: Show File Attachment events in Timeline
Description

Display Timeline entries for File Added and File Deleted events.

TagsNo tags attached.

Activities

Zipher

Zipher

2017-07-26 09:26

reporter   ~0057333

Please review this on PR #1136. Thank you.

atrol

atrol

2017-07-26 09:58

developer   ~0057334

But I am only able to add the translation for English and Traditional Chinese

Don't change any other language file than English in code repository.
Translations are managed via TranslateWiki, which means that TranslateWiki checks about every two weeks for changes in English files.
New messages will appear on TranslateWiki as not translated, giving Mantis users the chance to translate them.
The translated messages are commited to our repository by TranslateWiki [2]

Please refer our own Wiki [1] for the process to submit new translations or revise existing ones.

[1] http://www.mantisbt.org/wiki/doku.php/mantisbt:translationshowto
[2] https://github.com/mantisbt/mantisbt/commits?author=translatewiki

dregad

dregad

2018-02-10 19:00

developer   ~0058820

Last edited: 2018-02-10 19:12

View 2 revisions

New PR: https://github.com/mantisbt/mantisbt/pull/1294

Reworded the issue's description to reflect change in scope:

I had added a new event for class TimelineEevent. In order to show events for file added in issue in the timeline.

New PR also includes file deleted events.

Also I prevent events that have same issue id, user id, event type, and timestamp to show multiple times in timeline.
Such that when multiple files are added to issue at a time. There will be only one timeline event for this.

This has been reverted, because it introduces a regression with similar events (e.g. Tags). Having a single event for each file is consistent with how we handle tags, and offers the added benefit of displaying the attached file's name.

A new item $s_timeline_issue_file_added is introduce in the language file. But I am only able to add the translation for English and Traditional Chinese.

As mentioned previously by atrol, translations are handled by TranslateWiki.

Related Changesets

MantisBT: master 1067889a

2017-08-13 04:43:57

Zipher


Committer: atrol Details Diff
Show file added event in timeline.

1. Add class IssueFileAddedTimelineEvent to show file added event in
timeline.
2. Remove identical event from timeline.
Fixed issue 0023161
Affected Issues
0023161
mod - core/classes/IssueFileAddedTimelineEvent.class.php Diff File
mod - core/timeline_api.php Diff File
mod - lang/strings_chinese_traditional.txt Diff File
mod - lang/strings_english.txt Diff File

MantisBT: master e2547baa

2018-03-30 15:58:47

dregad

Details Diff
Show Attachments events in Timeline

Merge PR https://github.com/mantisbt/mantisbt/pull/1294

Fixes 0023161
Affected Issues
0023161
add - core/classes/IssueAttachmentTimelineEvent.class.php Diff File
mod - core/timeline_api.php Diff File
mod - lang/strings_english.txt Diff File

Issue History

Date Modified Username Field Change
2017-07-26 09:23 Zipher New Issue
2017-07-26 09:26 Zipher Note Added: 0057333
2017-07-26 09:58 atrol Note Added: 0057334
2017-08-02 08:01 dregad Assigned To => community
2017-08-02 08:01 dregad Severity minor => feature
2017-08-02 08:01 dregad Status new => acknowledged
2017-08-02 08:01 dregad Summary Show file added event in timeline => Show new "file added" event in timeline
2018-02-10 19:00 dregad Assigned To community => dregad
2018-02-10 19:00 dregad Status acknowledged => assigned
2018-02-10 19:00 dregad Target Version => 2.12.0
2018-02-10 19:00 dregad Summary Show new "file added" event in timeline => Show File Attachment events in Timeline
2018-02-10 19:00 dregad Description Updated View Revisions
2018-02-10 19:00 dregad Note Added: 0058820
2018-02-10 19:00 dregad Description Updated View Revisions
2018-02-10 19:12 dregad Note Edited: 0058820 View Revisions
2018-03-04 00:41 vboctor Target Version 2.12.0 => 2.13.0
2018-03-30 10:31 atrol Changeset attached => MantisBT master 1067889a
2018-03-30 10:34 atrol Status assigned => resolved
2018-03-30 10:34 atrol Resolution open => fixed
2018-03-30 10:34 atrol Fixed in Version => 2.13.0
2018-03-30 16:01 dregad Changeset attached => MantisBT master e2547baa
2018-03-31 19:58 vboctor Status resolved => closed