View Issue Details

IDProjectCategoryView StatusLast Update
0023206mantisbtmarkdownpublic2019-02-01 02:32
ReporterneumannAssigned To 
PrioritylowSeverityminorReproducibilityalways
Status newResolutionreopened 
Product Version2.5.0 
Target VersionFixed in Version 
Summary0023206: Markdown shows html tags in code-block
Description

If you indent some quellcode, markdown interprets this as quellcode but some special character are shown in the block as html code
z.B.
System.out.println("Hello World");

TagsNo tags attached.

Relationships

related to 0024628 assigneddregad When i have markdown enabled quotes are messed up 

Activities

atrol

atrol

2017-08-10 11:07

developer   ~0057423

I don't understand what you mean.
Please add screen shots of what you entered and what you get after it's rendered via Markdown.

Check also, if there is any other open issue in category markdown which might be a duplicate of your issue.

BTW, quellcode is very German ;-)

neumann

neumann

2017-08-11 05:10

reporter   ~0057432

I hoped to reproduce the markdown bug here in the description.
Now i have postet the screenshot. The text of the description is System.out.println("Hello World"); It should show the " and not the html tag (")

Maybe i can reproduce it here in the comment:
System.out.println("Hello World");



2017-08-11-Markdown.png (1,929 bytes)
2017-08-11-Markdown.png (1,929 bytes)
atrol

atrol

2017-08-11 05:48

developer   ~0057434

Did you change any source of MabtisBT or did you install any 3rd party plugin?

Do you see any errors or warnings when running admin/check/index.php?

neumann

neumann

2017-08-11 06:16

reporter   ~0057435

We are using the following pugins:
Email Reporting 0.10.0-DEV
Jquery Chosen 0.3
Source Control Integration 2.0.3
Source Subversion Integration 2.0.0

With admin/check/index.php we got no errors and some warnings.
Many of them from obsolete config or and wrong Paths.
This is the only warning i cant interpret something in:
Browser Search engine names must be 16 chars or less
Either shorten the "search_title" configuration option to a maximum of 11 characters, or alter the "opensearch_XXX_short" language strings as appropriate to meet the OpenSearch 1.1 specification for the ShortName element.

atrol

atrol

2017-08-14 12:28

developer   ~0057456

Are you able to reproduce the issue with a fresh install of MantisBT 2.5.1 without any installed 3rd party plugins?

neumann

neumann

2017-08-15 10:10

reporter   ~0057469

I installed a fresh mantisBT 2.5.1 without any 3rd party plugins and didnt get the error.
Then i installed alle the plugins and didnt get the error.
So Mantis is working fine with Markdown and the error has something do to with the Pluings or our installation.

Thanks for the help.

atrol

atrol

2017-08-15 11:10

developer   ~0057472

Thanks for the feedback.

neumann

neumann

2019-01-21 08:51

reporter   ~0061258

Last edited: 2019-01-21 08:52

View 2 revisions

The error happens again. I have a fresh installed Mantisbt 2.19.0 with markdown activated ( Manage Plugins -> MantisBT Formatting 2.19.0 -> Markdown Processing -> ON).
Now i want some source code thats starts with and ends with. In this Block i want to add " or <. These 2 symbols aren't converted.

Information to the System (Manage -> Site Information )
MantisBT Version 2.19.0
Schema Version 209
PHP Version 7.1.24-1+0~20181112093455.10+stretch~1.gbp09a4fd
Database Driver mysqli
Database Version, Description 5.7.22, 5.7.22-1

neumann

neumann

2019-01-21 08:54

reporter   ~0061259

In these 2 Screenshots you can see where the problem is.



EditNote.png (7,859 bytes)
EditNote.png (7,859 bytes)
Activities.png (8,940 bytes)
Activities.png (8,940 bytes)
atrol

atrol

2019-01-21 09:17

developer   ~0061260

@neumann I assume you are now encountering 0024628
Right?

neumann

neumann

2019-01-22 05:37

reporter   ~0061269

Yes thats the same Problem. The only thing i have to add is that < in nowhere mentioned .

Issue History

Date Modified Username Field Change
2017-08-10 10:52 neumann New Issue
2017-08-10 11:07 atrol Status new => feedback
2017-08-10 11:07 atrol Note Added: 0057423
2017-08-11 05:10 neumann File Added: 2017-08-11-Markdown.png
2017-08-11 05:10 neumann Note Added: 0057432
2017-08-11 05:10 neumann Status feedback => new
2017-08-11 05:48 atrol Status new => feedback
2017-08-11 05:48 atrol Note Added: 0057434
2017-08-11 06:16 neumann Note Added: 0057435
2017-08-11 06:16 neumann Status feedback => new
2017-08-14 12:28 atrol Status new => feedback
2017-08-14 12:28 atrol Note Added: 0057456
2017-08-15 10:10 neumann Note Added: 0057469
2017-08-15 10:10 neumann Status feedback => new
2017-08-15 11:10 atrol Assigned To => atrol
2017-08-15 11:10 atrol Status new => resolved
2017-08-15 11:10 atrol Resolution open => unable to reproduce
2017-08-15 11:10 atrol Note Added: 0057472
2017-09-03 05:31 atrol Status resolved => closed
2019-01-21 08:51 neumann Status closed => feedback
2019-01-21 08:51 neumann Resolution unable to reproduce => reopened
2019-01-21 08:51 neumann Note Added: 0061258
2019-01-21 08:52 neumann Note Edited: 0061258 View Revisions
2019-01-21 08:54 neumann File Added: EditNote.png
2019-01-21 08:54 neumann File Added: Activities.png
2019-01-21 08:54 neumann Note Added: 0061259
2019-01-21 08:54 neumann Status feedback => assigned
2019-01-21 09:17 atrol Assigned To atrol =>
2019-01-21 09:17 atrol Status assigned => feedback
2019-01-21 09:17 atrol Note Added: 0061260
2019-01-22 05:37 neumann Note Added: 0061269
2019-01-22 05:37 neumann Status feedback => new
2019-02-01 02:32 atrol Relationship added related to 0024628