View Issue Details

IDProjectCategoryView StatusLast Update
0023366mantisbtotherpublic2017-09-29 02:46
Reporterhelfy022 Assigned Toatrol  
PriorityhighSeverityminorReproducibilityN/A
Status closedResolutionno change required 
Summary0023366: use custom functions to control report/update category list?
Description

Hello,

This question is somewhat related to the following issue:

https://www.mantisbt.org/bugs/view.php?id=12465

Is it possible to use custom functions to present to the user a subset of applicable categories on the report or update bug pages? If it is not possible hide any categories to which a project may be linked (this is the question posed in bug 0012465), curious to know if custom functions can be used to accomplish the goal. Could some form of custom_function_default_enum_categories be set up and called to only present a subset of possible categories? Can that function (or a customized version of it) be called in a way that controls the category pull-down list in the report or update bug pages.

I'm envisioning a means of keeping available for viewing and filtering all categories associated with a project in the mantis_category_table. For new and to-be updated issues, though, it would be great to only make available a subset of the category collection going forward (and only a smaller list is shown). Eager to understand if custom functions can provide this functionality.

Please let me know if you would like any clarifications.

Thanks very much,
Ryan.

TagsNo tags attached.

Relationships

related to 0012465 new Disable Categories 

Activities

atrol

atrol

2017-09-16 16:21

developer   ~0057739

Custom functions are not the best way to write such kind of extensions.
Writing a plugin is the recommended way for it. https://www.mantisbt.org/docs/master/en-US/Developers_Guide/html-desktop/#dev.plugins

The best way to fix 0012465 is certainly to do it in core MantisBT.
Feel free to send us a Pull Request on https://github.com/mantisbt/mantisbt

helfy022,

This is not a bug or feature request for MantisBT (you are asking for help on how to develop an extension). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).