View Issue Details

IDProjectCategoryView StatusLast Update
0023502mantisbtfilterspublic2018-03-31 19:58
ReportercproensaAssigned Tocproensa 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2.8.0 
Target Version2.13.0Fixed in Version2.13.0 
Summary0023502: Filter "assigned to" does not account for configuration "view_handler_threshold"
Description

Regarding filtering, view_handler_threshold only is used to hide the selectable users for this property, but this is weak as:
1) The value can be stored in the filter by other means than inputting from the filter dialog
2) The option is evaluated at current project level, but the filter may reach other projects where the configuration is different
3) Because of 2, a user with permission in a project can use the filter normally, and see results from subprojects where he is not privileged.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master 71e74ef9

2017-10-19 19:52:52

cproensa


Committer: dregad Details Diff
Use view handler threshold in filter query

Fixes: 0023502
Affected Issues
0023502
mod - core/classes/BugFilterQuery.class.php Diff File

Issue History

Date Modified Username Field Change
2017-10-19 13:17 cproensa New Issue
2017-10-19 20:20 cproensa Assigned To => cproensa
2017-10-19 20:20 cproensa Status new => assigned
2018-03-05 04:19 dregad Changeset attached => MantisBT master 71e74ef9
2018-03-05 04:19 cproensa Status assigned => resolved
2018-03-05 04:19 cproensa Resolution open => fixed
2018-03-05 04:19 cproensa Fixed in Version => 2.13.0
2018-03-05 04:26 atrol Target Version => 2.13.0
2018-03-31 19:58 vboctor Status resolved => closed