View Issue Details

IDProjectCategoryView StatusLast Update
0023796mantisbtreportspublic2018-02-06 21:17
ReporterimqAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version2.11.0Fixed in Version2.11.0 
Summary0023796: Filter links for resolved/closed custom statuses in Summary By Status report are incorrect
Description

We customized the status values and added additional resolved status.

At page Summary -> By Status -> Resolved, for example,
For status #59, the link would be view_all_set.php?type=1&temporary=y&status=59&<b>status=58</b>&hide_status=99
For status 0000063, the link would be view_all_set.php?type=1&temporary=y&status=63&<b>status=58</b>&hide_status=99

Both links would turn the filter to have status set as #58 rather than #59 or 0000063.

TagsNo tags attached.

Activities

dregad

dregad

2018-01-09 09:39

developer   ~0058510

Looks like summary_print_by_enum() is tagging an extra status, to allow filtering of the resolved/closed issues. This behavior is reproducible in out-of-the-box MantisBT, but does not have any side-effect in that case, since both query parameters have the same value (80 or 90).

Can you please provide your settings for

  • status_enum_string
  • bug_resolved_status_threshold
  • bug_closed_status_threshold
dregad

dregad

2018-01-09 10:29

developer   ~0058511

@imq nevermind the request for additional information, I can reproduce the problem.

dregad

dregad

2018-01-09 10:45

developer   ~0058512

Clearing product version as the problem exists since the introduction of the hyperlinks in this report, 13 years ago... MantisBT master b51d5398

dregad

dregad

2018-01-09 11:02

developer   ~0058513

PR https://github.com/mantisbt/mantisbt/pull/1266

imq

imq

2018-01-09 21:29

reporter   ~0058515

I tested the change in 0023796:0058513 and seems there were some more fields having the same issue:

  • By Status -> closed column (in my case, the duplicated status does not matter. But guess it should be affecting those setting with multiple closed statuses)
    • view_all_set.php?type=1&temporary=y&status=99&status=99&hide_status=-2
  • By Severity / By Resolution -> closed and total column
    • view_all_set.php?type=1&temporary=y&severity=10&status=58&status=99&hide_status=-2
    • view_all_set.php?type=1&temporary=y&severity=10&status=58&status=99&hide_status=-2
dregad

dregad

2018-01-10 09:34

developer   ~0058523

Apologies, I didn't test my code thoroughly and failed to notice that the piece of code I updated was actually duplicated further down in the function, so my fix is only partial. I'll update the PR later.

dregad

dregad

2018-01-24 13:35

developer   ~0058603

@imq I have pushed an updated version of the branch which I believe addresses the problem in the Closed and Total columns you mentioned in 0023796:0058515. Could you please test and let me know if the issue is fixed now ?

Related Changesets

MantisBT: master 51e159c4

2018-01-20 19:31:46

dregad

Details Diff
Fix resolved/closed links for summary by status

When using custom statuses higher than bug_resolved_status_threshold,
the filter links for figures in the Summary page's "By Status" report
are incorrect for the Resolved and Closed columns.

This is caused by summary_print_by_enum() adding an extra 'status'
query parameter set to bug_resolved_status_threshold /
bug_closed_status_threshold (depending on the column being processed),
which overrides the status set for the row.

The code now skips adding the 'status' query parameter when processing
the Status enum, and only does it when processing other enums.

Fixes 0023796
Affected Issues
0023796
mod - core/summary_api.php Diff File

Issue History

Date Modified Username Field Change
2018-01-09 04:45 imq New Issue
2018-01-09 09:39 dregad Status new => feedback
2018-01-09 09:39 dregad Note Added: 0058510
2018-01-09 10:29 dregad Assigned To => dregad
2018-01-09 10:29 dregad Status feedback => confirmed
2018-01-09 10:29 dregad Note Added: 0058511
2018-01-09 10:45 dregad Status confirmed => assigned
2018-01-09 10:45 dregad Category customization => reports
2018-01-09 10:45 dregad Product Version 2.9.0 =>
2018-01-09 10:45 dregad Target Version => 2.11.0
2018-01-09 10:45 dregad Note Added: 0058512
2018-01-09 11:02 dregad Summary Links to customized resolved / closed statuses in Summary page are not generated promptly => Filter links for resolved/closed custom statuses in Summary By Status report are incorrect
2018-01-09 11:02 dregad Note Added: 0058513
2018-01-09 21:29 imq Note Added: 0058515
2018-01-10 09:34 dregad Note Added: 0058523
2018-01-24 13:35 dregad Note Added: 0058603
2018-02-01 12:03 dregad Changeset attached => MantisBT master 51e159c4
2018-02-01 12:03 dregad Status assigned => resolved
2018-02-01 12:03 dregad Resolution open => fixed
2018-02-01 12:03 dregad Fixed in Version => 2.11.0
2018-02-06 21:17 vboctor Status resolved => closed