View Issue Details

IDProjectCategoryView StatusLast Update
0023876mantisbtinstallationpublic2018-02-09 07:45
ReporteratrolAssigned Todregad 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version2.11.0 
Target Version2.11.0Fixed in Version2.11.0 
Summary0023876: Running admin/check fails
Description

Regression in master

Running admin/check gives

MantisBT Application Errors should halt execution
Continuing after an error may lead to system and/or data integrity issues. Set $g_display_errors[E_USER_ERROR] = DISPLAY_ERROR_HALT;
Steps To Reproduce

Set $g_display_errors = array(); and run the admin checks.

TagsNo tags attached.

Relationships

related to 0023955 closedatrol Warning message on login page 

Activities

vboctor

vboctor

2018-02-04 16:40

manager   ~0058737

I can't reproduce.

dregad

dregad

2018-02-04 17:51

developer   ~0058741

Added steps to reproduce

Related Changesets

MantisBT: master 41a29a06

2018-02-04 18:02:37

dregad

Details Diff
Remove admin check for Application Errors

This test is no longer necessary, as we are now enforcing handling
method DISPLAY_ERROR_HALT for all error types since commit
c816588d2616225f33896e7f4f4cd5a45447bce6.

Fixes 0023876
Affected Issues
0023876
mod - admin/check/check_config_inc.php Diff File

Issue History

Date Modified Username Field Change
2018-01-23 14:23 atrol New Issue
2018-02-04 16:40 vboctor Note Added: 0058737
2018-02-04 17:51 dregad Steps to Reproduce Updated View Revisions
2018-02-04 17:51 dregad Note Added: 0058741
2018-02-04 18:03 dregad Assigned To => dregad
2018-02-04 18:03 dregad Status new => assigned
2018-02-04 18:04 dregad Changeset attached => MantisBT master 41a29a06
2018-02-04 18:04 dregad Status assigned => resolved
2018-02-04 18:04 dregad Resolution open => fixed
2018-02-04 18:04 dregad Fixed in Version => 2.11.0
2018-02-04 18:05 dregad Product Version => 2.11.0
2018-02-06 21:17 vboctor Status resolved => closed
2018-02-09 07:45 atrol Relationship added related to 0023955