View Issue Details

IDProjectCategoryView StatusLast Update
0024042mantisbtfilterspublic2018-03-31 19:58
ReportertkAssigned Tocproensa 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.11.1 
Target Version2.13.0Fixed in Version2.13.0 
Summary0024042: filter on relationships mistuned by switching sort order
Description

I use filter on relationship.
This filter gets instantly mistuned when I try to change the sort order.

I suppose there is some internal variable overwritten by relation type counter, cf. steps to reproduce.

Steps To Reproduce

Initiate:
1.) Set filer on some issue number
2.) Apply filter
3.) Toggle change of sort order on any displayed column

Result:
4.) In the filters section issue number to be filtered for is changed:
In case of "parent of" ==> issue: "2"
In case of "child of" ==> issue: "3"
In case of "has duplicate" ==> issue: "4"

TagsNo tags attached.

Activities

cproensa

cproensa

2018-02-26 09:39

developer   ~0059040

This seems to be fixed by PR 1220
https://github.com/mantisbt/mantisbt/pull/1220

Issue History

Date Modified Username Field Change
2018-02-26 07:18 tk New Issue
2018-02-26 09:39 cproensa Assigned To => cproensa
2018-02-26 09:39 cproensa Status new => confirmed
2018-02-26 09:39 cproensa Note Added: 0059040
2018-03-05 06:49 cproensa Status confirmed => resolved
2018-03-05 06:49 cproensa Resolution open => fixed
2018-03-05 06:49 cproensa Fixed in Version => 2.13.0
2018-03-05 06:50 cproensa Target Version => 2.13.0
2018-03-31 19:58 vboctor Status resolved => closed