View Issue Details

IDProjectCategoryView StatusLast Update
0024107mantisbtlocalizationpublic2018-03-26 16:54
Reporterwindrienk Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version2.12.0 
Summary0024107: Translation jump to history not working
Description

The jump to history button is not being translated.

$t_history_label = lang_get( 'jump_to_history' ); is called but the language string is bug_history.

TagsNo tags attached.

Relationships

related to 0023202 closedatrol Questionable order and functionality of top buttons on "View Issue" page 

Activities

atrol

atrol

2018-03-13 06:14

developer   ~0059194

but the language string is bug_history

I don't see any error.
Isn't there $s_jump_to_history = ... in your language file?

atrol

atrol

2018-03-13 06:17

developer   ~0059195

Last edited: 2018-03-13 06:18

View 2 revisions

I assume you are using Dutch language settings, where no one translated this string (introduced in version 2.6.0) until now.

You can fix it yourself.
Translations are managed via TranslateWiki. Please refer our own Wiki [1] for the process to submit new translations or revise existing ones.

[1] http://www.mantisbt.org/wiki/doku.php/mantisbt:translationshowto

windrienk

windrienk

2018-03-13 06:20

reporter   ~0059196

I use the dutch language but there isn't a jump_to_history string. If I check the german language file there is, so it's missing in the dutch file.
Also here on this website, on top I see jump to history.

jumptohistory.PNG (1,953 bytes)   
jumptohistory.PNG (1,953 bytes)   
atrol

atrol

2018-03-13 06:31

developer   ~0059198

I use the dutch language but there isn't a jump_to_history string.

That's because of what I told before:

no one translated this string (introduced in version 2.6.0) until now

Translations are managed via TranslateWiki. Please refer our own Wiki [1] for the process to submit new translations or revise existing ones.
A few days after you have submitted the new translation, it will become part of the official Mantis source code and will become part of the next released version.

[1] http://www.mantisbt.org/wiki/doku.php/mantisbt:translationshowto

atrol

atrol

2018-03-16 07:24

developer   ~0059228

Will be part of 2.13.0 https://github.com/mantisbt/mantisbt/blob/master/lang/strings_dutch.txt#L88

Issue History

Date Modified Username Field Change
2018-03-13 05:31 windrienk New Issue
2018-03-13 06:13 atrol Relationship added related to 0023202
2018-03-13 06:14 atrol Status new => feedback
2018-03-13 06:14 atrol Note Added: 0059194
2018-03-13 06:17 atrol Note Added: 0059195
2018-03-13 06:18 atrol Note Edited: 0059195 View Revisions
2018-03-13 06:20 windrienk File Added: jumptohistory.PNG
2018-03-13 06:20 windrienk Note Added: 0059196
2018-03-13 06:20 windrienk Status feedback => new
2018-03-13 06:31 atrol Assigned To => atrol
2018-03-13 06:31 atrol Status new => resolved
2018-03-13 06:31 atrol Resolution open => no change required
2018-03-13 06:31 atrol Note Added: 0059198
2018-03-16 07:24 atrol Note Added: 0059228
2018-03-26 16:54 atrol Status resolved => closed