View Issue Details

IDProjectCategoryView StatusLast Update
0024242mantisbtbugtrackerpublic2018-06-06 00:39
ReportersandyjAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.12.1 
Target Version2.15.0Fixed in Version2.15.0 
Summary0024242: Incorrect issue status setting when changing status
Description

When following conditions are met when changing issue status, the issue will be set to incorrectly to assigned status rather than the status selected.
Conditions:

  • changing status of an issue from feedback to any other status (e.g. resolved) AND
  • Changing assigned field (to someone not you) in the change status form AND
  • Adding a note AND
  • You are the reporter of the issue.

Note that if you change the workflow threshold setting for "Set status on assignment of Handler" and "Status to set auto-assigned issues to" this can affect results. Changing "Status to set auto-assigned issues to" means that bug will change status to the same status set here (e.g. change this from assigned to new and issue are then incorrectly set to new).

Steps To Reproduce
  • Default workflow settings - "Set status on assignment of Handler" checked, "Status to set auto-assigned issues to" set to assigned.
  • Create an issue (i.e. you are the reporter)
  • set an issue to feedback status and assigned to yourself
  • select a new status other than 'assigned' (e.g. confirmed) and click "Change Status to"
  • select new user in assigned to dropdown in change of status form.
  • Add a note
  • Click submit.

instead of confirmed status, issue is set to assigned.

TagsNo tags attached.

Activities

sandyj

sandyj

2018-04-09 20:25

reporter   ~0059506

after more testing the "Set status on assignment of Handler" doesn't have any impact on the bug. Only "Status to set auto-assigned issues to"

vboctor

vboctor

2018-04-24 21:04

manager   ~0059670

I think this is caused by a feature that changes the status from feedback to assigned when the reporter comments on the issue.

if( $t_bug_note->note &&
    config_get( 'reassign_on_feedback' ) &&
    $t_existing_bug->status == config_get( 'bug_feedback_status' ) &&
    $t_updated_bug->status != $t_existing_bug->status &&
    $t_updated_bug->handler_id != $t_current_user_id &&
    $t_updated_bug->reporter_id == $t_current_user_id

I have a feeling that the fix is to change

$t_updated_bug->status != $t_existing_bug->status &&

to

$t_updated_bug->status == $t_existing_bug->status &&

But I haven't tested. Will check.

vboctor

vboctor

2018-04-24 21:52

manager   ~0059672

PR: https://github.com/mantisbt/mantisbt/pull/1344

Related Changesets

MantisBT: master d6b1afe8

2018-04-24 21:51:27

vboctor

Details Diff
Don’t auto-set status when explicitly set by user

Fixes 0024242
Affected Issues
0024242
mod - bug_update.php Diff File

Issue History

Date Modified Username Field Change
2018-04-09 20:18 sandyj New Issue
2018-04-09 20:25 sandyj Note Added: 0059506
2018-04-24 21:04 vboctor Note Added: 0059670
2018-04-24 21:52 vboctor Assigned To => vboctor
2018-04-24 21:52 vboctor Status new => assigned
2018-04-24 21:52 vboctor Note Added: 0059672
2018-04-24 21:53 vboctor Target Version => 2.14.0
2018-04-29 19:27 vboctor Target Version 2.14.0 => 2.15.0
2018-05-02 16:50 vboctor Changeset attached => MantisBT master d6b1afe8
2018-05-02 16:50 vboctor Status assigned => resolved
2018-05-02 16:50 vboctor Resolution open => fixed
2018-05-02 16:50 vboctor Fixed in Version => 2.15.0
2018-06-06 00:39 vboctor Status resolved => closed